AiO script & Python 3.6

I wondered if there is any thoughts on getting the AiO script to use python 3.6?

Happy to help test & look at what needs to be updated.


As a side note I noticed python 3.7.0 is out now, we better off using that?

1 Like

Python 3.7 is still in alpha.

The AIO script has some issues/PRs in for updating to 3.5, which makes sense because Stretch comes with 3.5. To have it support 3.6 it would also need to install Python 3.6.

My install on a Raspberry Pi 3 with a clean install of Raspbian Jessie with the All In One Installer and has worked great.

I have been able to automate much of my house using Sonoff Switches flashed with arendst Sonoff-Tasmoto firmware.

I have tried several different ways to upgrade my system to the new Python without success.

I have tried to install Hassbian and copy my existing .yaml files to the new install but nothing works. I have also tried to upgrade Raspbian Jessie to Stretch using my existing All in One Installation HA also did not work after this attempt. Is there detailed instructions on how to move my existing Raspbian Jessie All In One installation to a Hassbian installation?

If I am not able to upgrade my system with my existing working configuration how long will I be able to upgrade my working system? Just a reminder of a old saying “If it’s not broke don’t fix it”!!

Tinkerer: I have broken up my wall and tried to put my message into a better paragraph format so the group can better understand.

I have installed Hassbian on a clean chip but am having lots of issues moving my existing AIO installation to the Hassbian installation such as "Duckdns, Letsencrypt, Mosquitto.

I being a inexperienced Linux user would like to see a more detailed instruction how to move a AIO installation to Hassbian!!

I would also be willing to help test the modifications to the All-In-One-Installer so we can continue to update it with future modifications to Home Assistants!!

Thank You for the help!!

The key thing here is that you can keep upgrading, it simply doesn’t work for new installs.

Now, instead of any of those steps you tried, maybe you’ll find just upgrading Python (and the virtual environment) easier?

I will try the Python Upgrade.

The question I have is if “The key thing here is that you can keep upgrading, it simply doesn’t work for new installs” why do I keep seeing the following in my info section?

2017-11-19 07:24:15 WARNING (MainThread) [homeassistant.bootstrap] Python 3.4 support has been deprecated and will be removed in the beginning of 2018. Please upgrade Python or your operating system. More info:

You see that warning, because Home Assistant is removing support for Python 3.4. That’s completely separate from the All in One installer - it’s just that the AIO installer was for Raspbian Jessie, which came with Python 3.4.

Now, Home Assistant is removing support for Python 3.4, because one of the key libraries (aiohttp) is removing support for it. Moving to a minimum of Python 3.5 brings a number of other advantages in terms of performance.

Tinkerer: I have partially been successful in moving my HA config for AIO to Hassbian with 2 exceptions.

I have installed a Honeywell Lyric T5 Thermostat with the procedure outlined by Bram_Kragten Honeywell Lyric Thermostat .

Also I have 2 Amcrest IPM-943W Cameras.

I have not been able to make these work in Hassbian but both worked in my AIO installation.

Any help would be greatly appreciated.

I’d start your own thread about each of these, including any errors from the logs, and your configurations.

Just “they don’t work any more” isn’t enough to diagnose the problem :wink:

Sorry to bother you again!! I should have said what do I have to do to begin trouble shooting my errors. I will keep looking maybe someone else has similar errors.

Check your logfile for specific error messages about those components.

I gave up on Hassbian and went back to the AIO Installer with a new install of Raspbian Stretch. Everything is working after my manual install of Mosquitto but still having issues when I try to Install reinstall Mosquitto .
sudo apt-get install --reinstall mosquitto

The following packages have unmet dependencies:
mosquitto : Depends: libssl1.0.0 (>= 1.0.1) but it is not installable
Depends: libwebsockets3 (>= 1.2) but it is not installable

Hope I gave enough details.

1 Like

Execute: aptitude install mosquitto

That should take care of it for you.