AiO script tries to use python3.4 while the RPi has python3.5


My All-In-One installation over default Raspbian NOOBS is failing at this point:

[localhost] out: ln: failed to create symbolic link '/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages': No such file or directory
[localhost] out:

Warning: sudo() received nonzero return code 1 while executing 'ln -s /usr/local/lib/python3.4/dist-packages/cec /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages'!

I’ve received a connection problem error from the PuTTY on the 2 times I’ve tried. The power supplier is 2.5A and the cable looks good.

I’ve seen various reports of such error but much earlier this year, nothing actual, nothing with a solution.

Revising the folders on my RPi, I’ve found that both “/usr/local/lib/” and “/srv/homeassistant/homeassistant_venv/lib/” hold “python3.5” while the installation script states “python3.4”.
Clearly the command will fail.
What is the workaround? How can I edit the installation script?

Thanks in advanced.


It’s a known issue, and there is work underway to address this, but no sign of when it’ll be ready.

Thanks for your prompt response.
Can you tell me what will not work if I will start using the system as it is now? Or it is not possible at all?
I plan to use zwave sensors.


It is hard to say, but probably it will fail just after you think everything is ok.:disappointed_relieved:

The docker installation method should still work to run on an existing Raspian.

Thanks gpbenton. Never tried docker before. Good opportunity to start :wink:

Hassbian is an option if you’re happy to start with a fresh install.

Seems like I will have to, as the Docker option fails as well…


Following the discussion on the issue thread: Issue #60, seems the AiO can work. Thanks everybody for helping out here.