Airco won't trigger at 6am

Hi all,
I hope i’m in the right section here. I’m pulling my hare out on this issue with my AC.
I got fujitsu AC’s with a wifi module. They work with the fglair app.
I installed hacs and the fglair integration. It worked for a year without issues. But since my server had a HDD crash i had to reïnstall HASS.
It was then when i noticed i had been running some older version of HASS on my server.
No problemo… go and install everything i had back to HASS. But here comes my issue.

I’ve got an automation set for 6 am to turn the thermostat to 17C and turn on the AC in the living room. Now this trigger works but only the thermostat is turned to 17. The AC is still off.
When i run the automation myself it does work and AC goes on. If i set the automation to trigger a minute or few minutes after the current time it also works without issues. But only at 6am the airco won’t turn on.
I did a reïnstall of fglair that didn’t change antying. So i decided to reïnstall HASS again. But this also didn’t make a difference.
Putting the AC in it’s own automation didn’t make a difference either. Also setting that automation at 6:05am or 6:10 am didn’t made a difference.

Also, turning the AC on, off or to another temp or hvac setting does work without any issues from my dashboard card.

I’m running out of ideas now so i hope someone in here has a solution or idea for this issue.

Here’s some related info:

Code as shown below should work:

alias: "Klimaat: 6u aan"
description: ""
  - platform: time
    at: "06:00:00"
  - condition: numeric_state
    entity_id: climate.woonkamer
    attribute: current_temperature
    below: 18
  - service: climate.set_temperature
    metadata: {}
      temperature: 17
      hvac_mode: heat
      entity_id: climate.woonkamer
mode: single

It doesn’t do what the OP is attempting though: there are two different climate entities in play.

@Z0tteke — is anything else happening at 06:00 that might be overloading the integration or sending conflicting commands? Try inserting a 1s delay between each command in the action?