Alarm code is not working

Hello all,

This almost appears to be a bug but let me try here first

I setup a manual alarm component and it appears to work without a code set. However now,
It appears that If a add a code to the alarm, I get the following in the logs:

Invalid code given for armed_home
Invalid code given for armed_away

Depending on what I pick

I have tried to fix this issue by trying the code with and without quotes (") for code.
I have tried using the code in secerts.yaml and directly in the config yaml. I have also tried the manual alarm and the manual alarm with mqtt (examples below)

platform: manual
name: “14R Alarm”
code: !secret alarm_code
pending_time: 60
trigger_time: 60
disarm_after_trigger: false


  • platform: manual_mqtt
    state_topic: home/alarm
    command_topic: home/alarm/set
    pending_time: 30
    delay_time: 20
    trigger_time: 4
    name: “14R Alarm”
    code: “9999”
    trigger_time: 0
    pending_time: 0
    delay_time: 0
    pending_time: 0

To be clear, I see the code number panel in the alarm card but It just is not working for me.
I am using a docker install for homeassistant (not on 0.93.1
Any ideas on what I can do?

Same issue my panel just broke!

Just found out this is a known issue:

Using the pad not the keyboard is the workaround.

from .92 to .95.4 and still no fix or mention on this problem.