Alarm panel trigger, Ignore sensor during a specific times

Using the Alarm Panel Card which works fantastic…but have an external motion sensor that falsely triggers in the afternoon when it’s sunny, hot and blowing. Hence triggering false alarms.
Wondering how I could exclude the sensor input being recognised during certain times of the day say from 12:00 through to 19:00?

Here’s a snippet from my configuration.yaml with the sensor input and the condition that it triggers on.

      - platform: state
        entity_id: binary_sensor.konnected_da0476_zone_1
        to: "on"
      - condition: state
        entity_id: alarm_control_panel.home_alarm
        state: armed_away

Thanks in advance.


You could add the condition that the time is not between 12:00 and 19:00 like this:

      - condition: state
        entity_id: alarm_control_panel.home_alarm
        state: armed_away
      - condition: not
          - condition: time
            after: "12:00:00"
            before: "19:00:00"

Thanks Browet,

That would work. But should have mentioned have multiple input sensor, how could I then exclude that one sensor during that specific period? But still trigger on all the other sensors?


Than two options:

  1. I would create an automation specifically for that sensor… and another one for all the other sensors…
  2. I would use the “trigger condition” but never use it myself…
    In this case you have to test that the automation has not been triggered by the trigger index you want to exclude between 12:00 and 19:00
  condition: trigger

In the list of triggers, the first one has the trigger index “0”, the second one “1” and so on… You can also give a name the the triggers by using “id:” like this:

    - platform: event
      event_type: "MY_CUSTOM_EVENT"
      id: "custom_event"

More info here:

Thanks again,

That makes sense and logically would work. I’ll give that a go.

Merry Xmas!!