Alex Media Player Captcha missing

Unable to see Captcha image after upgrade. Have tried different browsers, clearing cache, downgrading several versions without success. Was working fine with 2.5.13

HA 108.3
Alexa Media Player integration/plug-in via HACS v2.5.14
tried downgrading to 2.5.13, 2.5.12

2020-04-21 (1)

What I do is “confirm” after that I always get a captcha to try it again


just tried that but no success.

If you try to open that broken image in a new window, I expect you’ll see some XML stating that the captcha is expired.

What worked for me is restarting HA and then immediately moving on to configure Alexa Media Player.


Yup - that did the trick - thanks

1 Like

Thanks for the tip, that worked for me too!

So, I got this, and the expired token.

I just entered 123(any random string will work of course) as the catchpa and hit the button, it immediately came back with a new one.

Saves having to restart HA

1 Like

This is the best and easiest solution :wink:

Doesnt work for me here. I add the calculated TOTP / 2 FA Code, und have to open a Browser window with an amazon captcha, but there is no way to enter the correct letters - i can read them very easily, but after entering and confirming, i have to enter the next captcha - and then the next and so on.


Hi @ eastpak1984 did you ever solve the repeating Amazon Captcha as I’m suffering exactly the same problem 2 years later… any help is much appreciated.

1 Like

Same here…

Exact Same situation. It works once. Then the integrations failed and I can’t login anymore. It keeps asking me for a captcha… With no error at all