Alexa Account Linking

Hi All,

I am trying to create my custom Alexa Skill and followed the instructions from . So far so good, but unfortunately I am Failing with the account linking.
Whenever I try to link my account I see the login screen of the hassio authorization page, when I enter my credentials it is redirecting me to my personal hassio Page and the account is not linked to Alexa.

I read all threads I could find and tried to change hosting location of the lambda to Irland and Virginia. I also tried the redirecting URLs * and without success.

Does anyone have an idea what else I can do to make this work ?



I am also having trouble with the account linking since I purchased a new router. I can access Home Assistant from the internet, but account linking with Alexa doesn’t work anymore. When I try to test the skill on the Alexa lambda site, I get the following error:

“START RequestId: a338ebdd-c641-4d1e-b101-099e83b65563 Version: $LATEST
[DEBUG] 2021-04-13T14:32:49.190Z a338ebdd-c641-4d1e-b101-099e83b65563 Event: {‘directive’: {‘header’: {‘namespace’: ‘Alexa.Discovery’, ‘name’: ‘Discover’, ‘payloadVersion’: ‘3’, ‘messageId’: ‘1bd5d003-31b9-476f-ad03-71d471922820’}, ‘payload’: {‘scope’: {‘type’: ‘BearerToken’}}}}
[WARNING] 2021-04-13T14:32:51.312Z a338ebdd-c641-4d1e-b101-099e83b65563 Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by ‘ConnectTimeoutError(<urllib3.connection.HTTPSConnection object at 0x7f4e5775b3a0>, ‘Connection to timed out. (connect timeout=2.0)’)’: /api/alexa/smart_home
END RequestId: a338ebdd-c641-4d1e-b101-099e83b65563
REPORT RequestId: a338ebdd-c641-4d1e-b101-099e83b65563 Duration: 3003.50 ms Billed Duration: 3000 ms Memory Size: 128 MB Max Memory Used: 53 MB Init Duration: 169.76 ms
2021-04-13T14:32:52.192Z a338ebdd-c641-4d1e-b101-099e83b65563 Task timed out after 3.00 seconds”

Since the router is new, I suspect it’s some kind of firewall issue, although, as I noted earlier, I can access Home Assistant using https (via letsencrypt), so my port forwarding of ports 80 and 443 seems to be working.

Anyone have any ideas?