Alexa Actionable Notifications Skill Error


New to HA and trying to implement @keatontaylor alexa actionable notification skill.

I have followed through the guide numerous times, tried other guides that use Powershell, all without success so far.

The issues seems to be that the skill cannot communicate with my HA. I am using the Nabu Casa URL and Log Token, but when I test I just get the reply “There was a problem with the requested skill’s response”

I’m a bit lost where to look for logs, but found these in CloudWatch.

INIT_START Runtime Version: python:3.8.v43	Runtime Version ARN: arn:aws:lambda:eu-west-1::runtime:b20481443932830049531ab20faaf09295061aff7a67a0b0f40496e5e1ddec59

LAMBDA_WARNING: Unhandled exception. The most likely cause is an issue in the function code. However, in rare cases, a Lambda runtime update can cause unexpected function behavior. For functions using managed runtimes, runtime updates can be triggered by a function change, or can be applied automatically. To determine if the runtime has been updated, check the runtime version in the INIT_START log entry. If this error correlates with a change in the runtime version, you may be able to mitigate this error by temporarily rolling back to the previous runtime version. For more information, see

[ERROR] Runtime.ImportModuleError: Unable to import module 'lambda_function': No module named 'isodate'
Traceback (most recent call last):

If anyone can help out that would be great as I have been through the setup at least 10 times nd cannot see what the issue is. It feels like it is an authentication issue, or an issue witht he skill being unable to connect to my HA server using the Nabu Casa link. script looks like this:

TOKEN = "eyJhbGciOiJIUzI***************************wNGQ5Yjg0MWY0YmE2OTUyNjg1MjRkN2NhM2VmMiIsImlhdCI6MTcxMDExMDA2NiwiZXhwIjoyMDI1NDcwMDY2fQ.u7mQWxcwR-df2SNc6OCJQte348hT5KKSyHZSjxWOgrw"
DEBUG = True


I too have arrived at the same error as you after numerous attempts to recreate my Actionable Notifications skill after successfully using it for nearly two years. Something has changed and we’re not alone. Have a look here at issue #242


I have solved my issue!
You need all of this in your lambda function:

Check my post on Github…