Home Assistant Community

Alexa Announce Feature - Text to Speach via Alexa now a possability?

alexa
Tags: #<Tag:0x00007fcf4f6984a0>
#447

i mean the right addon. rhere are several to retrieve cookies in firefox, and most of them dont work.
this one does.

#448

thanks ReneTode,

I tried it with this add-on
unfortunately no luck
keeps saying cookie expired…

so first it says cookie expired … and then after a while it says /tmp/.alexa.cookie: no such file or directory
Where to I need to have this cookie? I thought it was in the config directory…

#449

in the sh file you can see where the cookie is expected and how it should be called

i believe by default it was /tmp/cookie.json i am not 100% sure about that because i have changed that.

#450

i have checked and its expecting it to be in /tmp/.alexa.cookie Maybe I can try and change that to e.g. /config/cookie.txt?

#451

yeah right.
and make sure that the filerights are like they should be.

#452

sorry, but not sure what you mean with filerights?
Any settings I need to check to be sure?

#453

you are working on a system which is created for multi users.
so the filerights are based on that.
if you copy a file with samba the file will get the rights from the user you used to login with samba.
the sh file also gets activated by a user (probably homeassistant) so those users must have both the same rights. (or be the same user)

#454

hi ReneTode

moving from one problem to another I am affraid.
Now I got past the cookie part
if I try the command ./alexa_remote_control.sh -d “Living Room Echo” -e speak:Hello , it promts all the data in my putty connection, showing device id etc…m but no sound on the device itself

#455

if you are using Raidolo’s build make sure you edit the /alexa_remote_control.sh file and change all location based stuff to your location. He has it set to italian, also chmod 777 your cookie file

#456

i would try

-e "speak:‘hello’ "

other then that i can only say, go through this whole topic, and see which of the possible problems is the one thats yours :wink:

#457

will have to further read this tread, but now it works,sometimes,

1 Like
#458

@ReneTode - as I am running Hassio, should I run the .alexa_remote_control_plain.sh script as I read in some post in the tread?
I really would like to this to get going stable - I would like to stay with Alexa i.o. moving to google home
I think the condition I am now in is actually worse then before…before it was not working, period.
Now it is sometimes working and sometimes not working.

#459

then you need to try to find out what you do different in the moments that it isnt working.
but it is very well possible that a slow connection, makes that the call is timed out.
first step that i would take is look into the alexa app history, to see if your commands all come through.

there are several things around.
plain (which is i think nothing more then the original) which is just a linux executable.
something that is adapted for connecting to HA, which i believe has special output
the alexa_mediaplayer component.

i just use the plain. because i like to tinker
if you only want tts and not things like starting the weatherreport i suggest you start using the media_player component. if installed correct it seems a bit more reliable and more easy to use.

#460

Were you ever able to get the cookie generator working? I’m not even sure of the steps to follow. :frowning:
I am using amazon.com. last message I saw from you, was that you were having issues with .de

I we could get this working, this script would be perfect.

#461

i think you might get it working, but in my case it kept telling me that it couldnt login to some amazon.com pages.

edit: i found a workaround that is working for me now.
i’m sure its at least 2 weeks, so i get a warning now when i need to renew, and i have a sensor showing me if the cookie is still there.

#462

No rush, I’m out of town for work at the moment. But when you have some time would you mind sharing what you’ve done to automate the cookie process?

#463

pm me or contact me on discord when you got time and we will see if we can get it working for you.

1 Like
Best Speaker or configuration for TTS
#464

Should the other readers all PM you too? :slight_smile: If you can share what you have here, more people can benefit from it. …including those of us thinking “is this still a problem stopping me from getting an Alexa, or is this actually solved?”

Please share !

#465

i already shared and didnt succeed.
that doesnt mean that i cant try to get someone using another environment then me to get it up and running.
if i can help him and he will get it working, he for sure will share what we did get done.

and for those who are trying to decide if there should be a reason to buy an alexa?
if you think that this is what you need for you to buy it, then dont.

TTS is possible with this or with the mediaplayer component, but however you look at it, its a hack and not an official amazon supported feature.
all that is possible now with this hack or the mediaplayer component can be gone tommorow when amazon changes stuff! and you wont even be able to complain about it, because its nothing more then a hack!

if you dont mind that, then please spend a few bucks (wait for the next sale and you get it almost for free) and hack away. but dont expect anything presented on a platter. join in on the hacking.

satisfied @chickenandporn

#466

i See you miss the point. Sharing involves giving, and some vulnerability. It lets others take what you have and move it a step further.

To understand latency a bit better, send me a PM.