Alexa Announce Feature - Text to Speach via Alexa now a possability?

alexa
Tags: #<Tag:0x00007f48010945c0>

#1

With Amazon rolling out the new Announce function for Echo’s, will this open up possibilities for Ha to add in TTS support as it works for the Google Assistant/Home?

The feature is live on my Australian Echo’s now, and works making a recording of what I say and then repeating it to all other Echo devices on my network. It would be great to see this integrated in HA.


Make Alexa do Anything via homeassistant! Even TTS via Alexa!
Use echo device as text to speech?
Anyway to expose a sensor value to Alexa/Echo/Google
Running alexa_remote_control.sh inside Hass.io
Send Commands to Alexa
Echo Devices (Alexa) as Media Player - Testers Needed
HA and Mental Health
Ask alexa about a sensor state
Is it possible to set off the alarm on an Alexa device?
#2

I am looking for this feature as well. Any updates?


TTS (Text to speech) Alexa Working
#3

No other replies yet unfortunately.


#4

it is still not possible without some extras.

this feature works like this:

human voice > send sound to amazon > STT > send text to other devices > TTS > Alexa voice

you cant do without the first 3 steps.
so it is only possible if you use another device to speak to alexa.

for instance:
place an RPI with a small speaker somwhere in a backroom besides a cheap echo dot
and let the RPI speak to alexa
then it will be broadcasted from there.


#5

Seems to be working in OpenHab


#6

thats quite a hack they use there.

i think ill wait untill lötzimmer adds it to his remote control.


#7

Same here. All I can see from lötzimmer code is he is replicating calls from the Amazon web interface. How is speech working?


#8

if i see it correctly the openhab connection uses the mobile app to set things.
the web app that lötzimmer uses doesnt have the routines part (yey)
and you need the custom part from routines to let alexa speak text.


#9

I’ve been trying to use this as it looks like it now supports TTS however I can’t login, maybe it’s because I’m in the UK using Alexa.amazon.co.uk

Has anyone here successfully managed to get TTS to an Echo working via this method? Seems to be so close and a reality now.


#10

I’m in the UK, there is no direct TTS in the Amazon app. I setup a PI zero with openhab and the push calls to my Echo work very nicely. Cannot get to grips with the multiple interfaces of openhab and having just moved my infrastructure from Domoticz to HA I’m in no mood to change everything to openhab. The concept works but as @ReneTode said it is quite a hack. If Amazon change any option in the apps the hack may no longer work


#11

Sorry forgot to post link

TTS is mentioned at bottom of the page as an option for the script


Alexa Routines: "Alexa, Goodnight" = Turn Off X,Y and Z
#12

That’s good news. This is script mentioned by @ReneTode earlier in the previous posts

Will start looking at it now :slight_smile:


#13

Got the script working from my HASSIO HA container :slight_smile:

Install SSH add in. Log into the HA via SSH. Ensure you can resolve DNS if no edit /etc/resolv.conf and add a valid nameserver

ensure the script is executable with chmod -x

for UK edit script with these setting

LANGUAGE=“en-uk”
AMAZON=‘amazon.co.uk
ALEXA=‘alexa.amazon.co.uk

SCripts run perfectly . Now to see if I can control from HA :slight_smile: :slight_smile:


#14

Script it running perfectly for me now too thanks, had the wrong option for ALEXA=

I can run TTS commands (or any commands and get a response that looks to be successful but the Echo does nothing)


#15

try these options :

-a

This will give a list of Echo’s

then

-d “echo name” - e speak:“Im alive”


#16

-a gives me a list

adding the echo name or ALL in -d “echo name” - e speak:“Im alive” sends the commands (can’t copy and paste all of it for obvious reasons"

sending cmd:{“behaviorId”:“PREVIEW”,“sequenceJson”:"{"@type":“com.amazon.alexa.behaviors.model.Sequence”,“startNode”:{"@type":“com.amazon.alexa.behaviors.model.OpaquePayloadOperationNode”,“type”:“Alexa.Speak”,“operationPayload”:{“deviceType”:“REDACTED”,“deviceSerialNumber”:“REDACTED”,“locale”:“en-UK”,“customerId”:“REDACTED”,“textToSpeak”:“hello”}}}",“status”:“ENABLED”} to dev:Everywhere type:REDACTED serial:_REDACTED_customerid:REDACTED
Sequence command: Alexa.Speak
HTTP/1.1 0 x-amzn-RequestId: REDACTED
Access-Control-Allow-Origin: https://alexa.amazon.co.uk
Content-Encoding: deflate
Vary: Origin
Access-Control-Expose-Headers: x-amzn-dat-gui-client-upgrade,X-Amzn-Error,loginUrl,X-Amzn-RequestId,x-amzn-alt-domain,Date,Location
Access-Control-Allow-Credentials: true
Date: Wed, 20 Jun 2018 20:34:00 GMT
Connection: close

But nothing from the Echo or Echo’s


#17

[email protected]:/home/homeassistant$ sudo ./alexa_remote_control.sh -a
the following devices exist in your account:
Livingroom Echo
Michael’s Fire
Bedroom Dot
Bedroom
Hallway Dot
Kitchen Dot
Michael’s Echo Spot
Michael’s Sonos One
Living Room
Everywhere
Michael’s Fire TV stick
Michael’s Fire TV
Michael’s 2nd Fire TV
This Device
Michael’s Alexa Apps

Have been ignoring the devices with ’ e.g. Michael’s just in case. But still no response from the Echo.


#18

I’M running in Hass.io you may need some dependencies to run the Json Parser ?


#19

Just tried to plain non-jq version with same results. Strange, maybe something to do with my account.


#20

finally, i already have that script implemented in my appdaemon, so all i need to do is update the script!!

ill try that as soon as i have the time