Alexa Announce Feature - Text to Speach via Alexa now a possability?

alexa
Tags: #<Tag:0x00007f4801cd6a68>

#205

same result?
how can you connect to de and to uk?
you should only have 1 account on 1 of the both.

if you go to alexa.amazon.de or to alexa.amazon.co.uk
on which of the both can you login and on which one can you change the settings from your echo?


#206

According to your output, the Amazon server received the speak request. (HTTP/1.1 200 OK). At this point, the script has done its job. If the speak request doesn’t show up in the History on your Alexa console then I don’t know what else to suggest since you’ve already tried it from different servers. :frowning:


#207

I tried to use all language de,uk,us and did a new setup even use with no firewall with LTE internet same problem iam not using if amazon alexa check for geo ip.


#208

is your echo working at all?


#209

Yes it work with routines and skills.


#210

with which server do you change your settings?


#211

When you say check your “History on your Alexa console”. Where can I find the alexa console?


#212

Also, I’ve gotten everything setup according to the instructions however when I run the script my echo will not speak.

I have gotten a 200 back from the command
My customer id matches

Any other ideas of why my echo isn’t saying anything?


#213

go to your alexa account in a browser and see the history in settings.


#214

Despite getting 200’s from my curl’s I’m not getting any activity in my alexa history. My device info and the info on the alexa console also match.


#215

echo 1 or echo 2?


#216

Dang, I think I might have a 1st gen. Does it only work with 2nd gen?


#217

The Alexa portal/console is located @ https://alexa.amazon.com/. After you login, on the left side, select Settings. Now scroll down to the Alexa Account section and find the link for History. This page will show history for your Alexa devices.


#218

i am not sure, but it might be the trouble.


#219

I have 2nd gen Echodot mini.


#220

This worked for me. Had to use firefox for the cookie. Wish we could set volume to prevent shouting…


#221

you can set volume also.

the command for that is:

alexa_remote_control.sh -d “device” -e “vol:50”
50 represents a number betweem 1 and 100


#222

i just noticed that you did show your command like this:

alexa_remote_control.sh -d “Echodot” -e speak:This_is_a_test_longgggggggggggggggggggggggggggggggggggggggggggg_test

that should be

alexa_remote_control.sh -d “Echodot” -e speak:'This is a test longgggggggggggggggggggggggggggggggggggggggggggg test'

#223

The correct for me is
sudo ./alexa_remote_control.sh -d Living -e speak:‘This is a test long test’
The command is right but i dont get audio. I see that on the log that speak is being accepted. I have the Device in Sweden maybe they block the geo ip.


#224

if you have a working echo then there is no geo ip blocked.
but you need to make sure that you use the same account for the echo as for the code.
you can only use 1 account, so pick de or uk and then make sure that the echo is connected to that account and use that account in the code