Alexa Automatic Exposure Not Working

In the last few days new scripts are not automatically being sent to Alexa and updates to script names are not happening. I have not changed anything in the Alexa Voice Assistant settings. I am having to go find the new script and manually expose it to Alexa and do the same for the changes to names.

Any suggestions?


I have tried many of the suggestions to get this working with some limited success. I logged off and back in to Nabu Casa, turned off the Alexa Voice Assistant and disconnected and reconnected the HA skill in Alexa. Finally all the script entities were showing in the Alexa Voice Assistant as exposed. However about 16 scripts were still not appearing in the Alexa app. I had to go into those individually stop exposing them and then expose them by flipping the toggle to get them to expose. This is a recent issue after a HA update about a week ago. In the past a new script was automatically exposed and I was instantly alerted by Alexa that it was added.

Please take a look at this behavior.


Sorry, I forgot to mention why I went on a binge to fix this today. Suddenly this morning, several scripts we use multiple times every day disappeared from the Alexa routines they were in and the Alexa app. They were still showing in HA as exposed.