Alexa driving HA nuts!

I have completely redone my my alexa exposure in HA. Previously I had exposed all switches, lights and groups to the emulated hue component. The result was effective by a PITA. I had devices in discovery under the Royal Phillips Hue and for some reason most also exposed as non-Hue devices. Some of the Hue devices worked, some did not so I had to find the ones that did not work and delete them.

Forward to today… all of my Tasmota devices now have Wemo emulation turned on and also talk MQTT to HA, Alexa discovery now sees the Wemo devices only, no emulated Hue entries as I cut my exposure to Alexa way down in the configuration.yaml file. The results are exactly what I wanted!

Current emulated Hue config:

  expose_by_default: false
  listen_port: 80
      name: "desktop"
      hidden: false
      name: "plants"
      hidden: false

Now to the problem… I deleted the emulated_hue_idx.json file and rebooted all of my Alexa devices, now my json file only includes the 2 selected entries. But my log file is a constant stream of the following:

2020-05-05 10:28:00 ERROR (MainThread) [homeassistant.components.emulated_hue.hue_api] Unknown entity number: 52 not found in emulated_hue_ids.json

If it was 1 entry it would not kill me, but it is every entry from the old file and I can’t figure out what is trying to find the old entities.

Have been through numerous reboots, numerous Alexa reboots and I thought I had it tracked to one dot so I deregistered it and ran setup on it. As soon as it reattached to my wireless network the error level shot back up, so it did not forget the old stuff even through a factory reset?

What gives?

So, no one else sees this or has had to make it stop?

I finally was able to find the one amazon device that would not forget about the old entries, deregistered it and reset it.

Problem solved.

Hi, sorry to revive this, but could you tell me how you found the Alexa device that was retaining the old Royal Phillips devices? I’ve had a similar situation for awhile and I’ve just disabled the devices in the Alexa app, but I finally want to do something about it permanently.

I deregistered 1 at a time until it was fixed. 5th out of 6.

:laughing: …I was afraid you were going to say that’s how you did it.