Alexa - Input Boolean Switch Issue

Hi,

My input-boolean switches recently stopped working in Alexa. If I open the Alexa app and check on the switch in the device list, I can see the attached interface. No way to turn the switch on and off. Anyone experiencing the same? Any idea how to resolve it?

Google Photos

What am I using these switches for? E.g. when the switch turned on, automation runs and calls a script, which turns off the switch and turns off some other devices, lights, etc. I used this in Alexa to say Good Night, this turns on the input-boolean switch and turns off everything in the house… Is there a better solution for that? I am using HA cloud services.

Thank you!

I notice that you are doing a “Good Night” routine. I ran into the same problem and it turned out to be the Alexa ‘Good Night’ response. It seems that they broke it, and nothing after the Alexa response would get triggered. I removed her response in the Alexa app, and everything started working again.

2 Likes

Thanks, I will definitely check on this and report back here.

@bakerbug - you are right, I created a new routine with a different command than “Good night” and it is working. Thank you!

1 Like

It’s not just in the “Good night” routine. I have a “time for bed” routine and the same thing happened to it. When I removed Alexa’s responses, it started working again.

I configured another routine with a custom response and it is working for me. I only have two thing in the routine, say an answer and enable an input-boolean switch.

2 Likes

This seems to be the case with all Alexa predefined routines.