Alexa Media not working

I live in Romania and purchased some a few months ago some Amazon Echo’s to integrate with HA. I’ve added the HACS addon and then configured it with my amazon account. But the speakers don’t work, nothing comes out of them. I’ve tried to configure them multiple times, I switch to Germany as the region in amazon (2), I used the as my site when configuring it (3) (I also used .com, I’ve added the config part as I think that was the old way of doing it but still doesn’t work). Lastly, I’m trying to test it with tts but nothing is working ( not even if I wake the speaker prior to executing the action).

Can someone help? :sweat:


This is what my messages look like (and they work!) :

alias: Alexa Announce Error Clear
icon: mdi:comment-quote
  - service: notify.alexa_media
        - media_player.office_flex
        type: announce
      message: >-
        System Issue Resolved, {{
        states.sensor.zabbix_alerts.attributes.subject.split(':')[1] }}.
mode: single
1 Like

As @Neil_Brownlee says, you need to use the notify.alexa_media service with a target. As here in the docs:

Hello @Neil_Brownlee and @Holdestmade and thank you for your help.
I’ve tried Neil’s script and also the yaml example from the link provided by Holdestmade, but nothing happens, everything runs successfully but no audio.
Don’t really know what’s going on.

service: notify.alexa_media
message: Test message
title: Test
target: media_player.echo_dot_office
type: tts

What is the state of media_player.echo_dot_office ?

Can you control the volume from the media player entity ?

If your media player entity is unavailable the issue is most likely in your how you have configured your integration.

You must use the region ip that your Amazon account is set up under, you can’t mix and match. You do not need the entry in configuration.yaml and having both a UI and yaml config for the integration has been known to cause issues in the past.

FWIW, there’s nothing wrong with your example automation. You do not need to specify a target when you use one of the notfy services that include the device i.e. notify.alexa_media_echo_dot_kitchen.

I’ve used the integration without the confirmation.yaml info, but still didn’t work.
First I had the region set to Romania, after I switch it to Germany as in the photo from my post and used as site, I don’t know if because the region was initial set to Romania, causes the issue. I’m really lost for a couple of months.

When you say region IP it means if my regions in Amazon is set to Germany and ip is from Romania, it causes a conflict? (Amazon isn’t present in Romania)

Unavailable, but if I wake the speaker with “Alexa” it appears only, but controlling the volume doesn’t work. Even if I awake it and then run anything on it, still doesn’t work.

I have the same issue. Also in Romania. If you find any fox please port it. It drives me crazy! Thanks!

I have the same problem. Bought device at, installed it in Slovenia (but with account).
Any more ideas?

1 Like

I found problem. You have to use Remove integration, added again and this time working perfectly.
Error logs from HA: “Domain does not match reported account domain; functionality is not likely to work, please fix”


Hi all,

I have same problem with (my devices and everything is in spain, just checked at my user profile in amazon). I just reinstalled and configured to (in alexa media) and it seems to work (is in standby mode, not unavailable). I’ll check this afternoon.
Thanks @kastro

1 Like

just wondering if this is the case with me, as I have no sound or volume controls and can’t understand it but I changed to to instead of Is there a way I change it? or do i need to re-install it.

I just removed it and re-downloaded it again and when setting up the Alexa Media Player part filled it in with instead of which has done the trick all working now. so glad I saw your post! Thanks!