Alexa_media play sounds - more sounds

Tags: #<Tag:0x00007f328171bd48>

With the alexa_media component we can use the play sounds option to play different sounds that alexa supports. The wiki has an example using some sounds (https://github.com/custom-components/alexa_media_player/wiki#examples) but i’d like to use one of the additional sounds that the link to https://developer.amazon.com/en-US/docs/alexa/custom-skills/ask-soundlibrary.html.

The examples they provide just use the name but that doesnt work for the sound i want to work. I’ve tried several different variations but cannot get the sound to work. The one i’d like to use is

soundbank://soundlibrary/alarms/chimes_and_bells/chimes_bells_09

I’ve tried putting in the full path, parts of the path and just the name and cant get it to work. Anyone know how to get other sounds to work?

2 Likes

??? You forgot to paste the name in.
Have you tried multiple things like

  • fire_extinguisher_07
  • fire_extinguisher/fire_extinguisher_07
  • air/fire_extinguisher/fire_extinguisher_07

You can always use the ones under “Known available sounds”.

Yeah i’ve tried

  • //soundlibrary/alarms/chimes_and_bells/chimes_bells_09
  • /soundlibrary/alarms/chimes_and_bells/chimes_bells_09
  • soundlibrary/alarms/chimes_and_bells/chimes_bells_09
  • /alarms/chimes_and_bells/chimes_bells_09
  • alarms/chimes_and_bells/chimes_bells_09
  • /chimes_and_bells/chimes_bells_09
  • chimes_and_bells/chimes_bells_09
  • /chimes_bells_09
  • chimes_bells_09
1 Like

You can download it, and then upload it to your HA server, and then play it from there. You can play other stuff from HA too right? You can try prefixing amazon_sfx as well.

I was pulling my hair out on this the other day. Tried all those combos as above and never could get any from that huge sound lib to work. I figured maybe it was an Amazon device issue. Maybe my echo is too old.

I use the HA example and it works for me.

  door_bell_alexa:
    sequence:
      - service: media_player.play_media
        data:
          entity_id: media_player.ai_1
          media_content_type: sound
          media_content_id: amzn_sfx_doorbell_chime_01

Can we provide our own sound? I have sampled a handful from amazon’s library, but haven’t found one I like.

I guess you could add it to your amazon music library…

Did you ever resolve this? I have come across the same problem

Same issue over here, only a very small subset of sounds on their list works.

Seems it’s not working with the play_media service, but with notify and type TTS.

This works for me:

data:
  data:
    type: tts
  message: >-
    <audio
    src="soundbank://soundlibrary/computers/fax_scanner_copy_machine/fax_scanner_copier_14"/>
service: notify.alexa_media_echo_office

Thanks, that works for me as well

1 Like