Alexa Media Player failed to Login

Hi Team,

I am trying to install alexa media player but unable to get sccess.

Installed alexa media player through HACS. I am able to find the alexa media player in the integration page i filled the information as per the instruction

  • amazon login email address
  • amazon login password
  • url
  • 2FA code blank
  • built in 2fa(got it from amazon and pasted in this section)
  • Enable outh token app method ( tried both checked and unchecked)
  • Use login proxy method ( tried both checked and unchecked)

It is stuck on this screen and keeps on rotation at the bottom.

Logger: custom_components.alexa_media.config_flow
Source: custom_components/alexa_media/
Integration: Alexa Media Player (documentation, issues)
First occurred: 0:30:08 (1 occurrences)
Last logged: 0:30:08

Unknown error: Expecting value: line 1 column 1 (char 0)

FYI - I am using duckdns with lets encrypt.

Please someone help me.


Do you know how to uninstall this NOW utterly useless virus from the HA installation. if you do please please please let me know.

Did you figure this out? Having the same problem. I live where there is no local Amazon retailer and I’m not sure where to put my amazon.url . I currently have no Alexa devices. Could that be the problem? I only want this working to be able to trigger amazon routines from HA as I have some devices that do not work with HA but work with Alexa.