Alexa Media player MP3

I’m working on setting up an alarm. I have it all working put can not get the audio alarm sound to play on my Alex Eco. th is the code I’m using;
‘- service: media_player.play_media
entity_id: media_player.everywhere
media_content_id: ttp://’
media_content_type: ‘music’ ’
Any idea what I have wrong?

What I know this is not possible…

You might find something useful from this thread:

You basically need HTTPS for it to work and it has to be a specific certificate as Amazon only accepts specific kind of certificates.

On what device are you running HA? I have a work around for this if you are running HA as docker and the this host device is near the amazon echo of your interest. If these two conditions are fulfilled, first install mopidy player in the Host device, secondly connect the Host device to echo using bluetooth as audio sink, Third add mopidy to HA and finally call service to play the mp3 by mopidy which should be stored in the host device.

It is running on PI 3B+.

So it can not work internally from a PI 3B+

Is it running in docker or the HA OS?

I don’t think it’s impossible just not as easy as e.g. google devices.

Amazon requires both specific certificate and specific settings for the mp3 audio. So far I’ve also not been able to get it to work. I have only been able to play audio from a public Amazon S3 bucket

E.g. audio files from here do work if you want just some sounds and not custom audios

For the time being playing a local mp3 in echo devices is not possible. But since you are looking for an alarm. You can think of triggering echo device to play a music from any of the streaming service available in amazon alexa device. This is supported. Or you will have to use the Bluetooth but it needs HA to be installed as a docker in a OS like Raspbian. I you are looking for Bluetooth Please refer

So I could call it from the web addresses?

You copy the address to the individual mp3 (e.g. and put that in your automation instead for the link to your local mp3 file

1 Like

Thanks for all the help.

this is my automation, it all works except for the audio file playing.

alias: 'Send notification when alarm triggered'
  - platform: state
    entity_id: alarm_control_panel.home_alarm
    to: 'triggered'
  - service: notify.mobile_app_daves_new_xxxxxx
      message: "ALARM! ALARM! The alarm has been triggered"
  - service: media_player.play_media
      entity_id: media_player.everywhere
      media_content_id: ''
      media_content_type: 'music'

I’m at a lose?

Try audio/mp3 instead

Just tried that still not working.

This worked fine for me. Also with music. All I can think is check your external and internal url in the settings if they are defined and define them if not

Hi, can u share your script/automation/etc working with externals .mp3 and alexa?