Alexa media player not using oauth

I am getting a seemingly innocuous log warning “/usr/local/lib/python3.8/site-packages/alexapy/alexalogin.py (WARNING) No access token found; falling back to credential login instead of oauth” for some time, not sure when it started.

I installed “Alexa smart home skill” https://www.home-assistant.io/integrations/alexa.smart_home/ about 18 months ago, and all Alexa home assistant functions have been working fine since then. About 6 months ago I added 2FA to the Alexa media player integration when prompted for login.
I have removed and reinstalled Alexa media player integration, rechecked my Alexa smart home client id and client secret are the same as shown on my aws lambda page and removed then reenabled the custom Alexa app without effect on log warning. Does anyone have idea what might be wrong. Since everything is working, I am not inclined to try to fix anything

1 Like

Its not an issue per se, but here was my situation:

I’m getting the same error. Reinstalling the entire plug-in didn’t help. Nor did deleting the accounts, and reloading.

Same here as well. Maybe we should open an issue? I would do it but don’t really know how,lol

I don’t either. Looks like it’s in the lap of the gods. :slightly_smiling_face:

Anyone ever figure out how to enable oauth? I am being told my echo’s status are not updating because I dont have oauth enabled.

Having the same problem, followed the instructions, got the long code number from Amazon, entered it, works for 5 days the asks to Authenticate again.

Re Dave

I had the same situation. It’s basically turning on 2FA on the Amazon page. Two-Step Verification (2SV) Settings they call it. Once you have that turned on, you delete the current integration, and any reference to it in configuration.yaml, and reinstall it. There is a guide on the integration page.

Can anyone tell me how to overcome? I have over 1000 errors daily. A selection tagged below.
I have gone to great extent over the past few months with no reply.
Including a completely new install reinstalling each integration.
Can anyone please help?

2022-04-27 10:18:38 ERROR (MainThread) [homeassistant.components.alexa.state_report] Error when sending ChangeReport for binary_sensor.garage_door to Alexa: INVALID_ACCESS_TOKEN_EXCEPTION: Access token is not valid.
2022-04-27 10:53:33 WARNING (MainThread) [homeassistant.components.http.ban] Login attempt or request with invalid authentication from ec2-18-210-7-77.compute-1.amazonaws.com (18.210.7.77). (python-urllib3/1.26.6)
2022-04-28 03:38:54 WARNING (SyncWorker_1) [homeassistant.loader] We found a custom integration alexa_media which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant
2022-04-28 03:39:00 WARNING (MainThread) [alexapy.alexalogin] No access token found; falling back to credential login instead of oauth.
2022-04-28 03:39:01 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [140686321616064] Received invalid command: mobile_app/push_notification_channel
2022-04-28 03:39:01 WARNING (MainThread) [alexapy.alexawebsocket] mac_dms not detected; websocket likely won't connect
2022-04-28 04:08:24 ERROR (MainThread) [frontend.js.latest.202204050] :0:0 ResizeObserver loop completed with undelivered notifications.

Sounds like you haven’t enabled the 2FA login.

I have been chasing this issue longer that I can remember. Till now, no one has offered any help.
I have tried everything I can think of… Including deleting everything and re-install. This is what I call my brute-force method (Start Over). the interesting thing, and maybe you can clarify… F2A… I have about 5 various passwords for Amazon… to include what I refer to as F2A being an app on my cell phone called authy in which the code is changed every 30 seconds… The last round was painful!

But I got it operational once again, and yes, the

2022-05-17 11:21:55 WARNING (MainThread) [alexapy.alexalogin] No access token found; falling back to credential login instead of oauth.
2022-05-17 11:21:56 WARNING (MainThread) [alexapy.alexawebsocket] mac_dms not detected; websocket likely won't connect

is back taking my log hostage such that I rarely can seek out the important stuff…
Thoughts?