Alexa no longer can talk to home assistant

I have a Hassbian/rPi3-based home assistant install at version 0.63.1. It is linked to the Amazon Alexa app and it has been working for several weeks. About 3 days ago, I tried to use Alexa to turn on a light and she replied “Light is not responding”. Since then, all requests for all devices return the same response.

What I have done so far to troubleshoot this is:

  • Delete devices in the Alexa app and rediscover. This worked originally(same devices discovered) but the original problem persisted.
  • In Alexa, I disabled the Home Assistant skill and then re-enabled it along with a new discovery. That worked too (same devices discovered) but the devices still “are not responding”.
  • Of course, I restarted HA a million times and rebooted the rPi a thousand times with no change in the behavior :slight_smile:
  • Finally, I saved off all of my configuration files and reinstalled Hassbian. Now, after installing the Home Assistant skill in Alexa, device discovery finds nothing.

Can anyone help me learn how to tell whether Alexa is actually communicating with HA during discovery and if so, what is being returned? Is the discovery performed by my phone on the local network or is it conducted by a server outside of my network? Does the Echo perform the discovery? I’m guessing that it does not.


What platform are you using to link HA to alexa?

Emulated hue, haska, Cloud?

I guess that would have helped. I’m using cloiud:

# Cloud
        - light.master_bedroom_light
        - light.marcs_nightstand_light
        - light.pats_nightstand_light
        - light.living_room_light
        - light.curio_cabinet_light
        - switch.master_bedroom_fan
        - switch.living_room_fan
        - switch.noahs_bedroom_fan
        name: Master Bedroom Light
        name: Marcs Nightstand Light
        name: Pats Nightstand Light
        name: Master Bedroom Fan
        name: Living Room Light
        name: Living Room Fan
        name: Noahs Bedroom Fan

I figured this out. It was after creating the simplest configuration.yaml with a couple of switches and the cloud/alexa configuration. That didn’t help but after re-reading the setup pages a few times, I was motivated to check to see if the cloud login was being done on the Configuration page. It wasn’t. All I had to do was re-enter the login information and log in ro the cloud and it’s all working again.

My only question now is what causes the automatic cloud login to stop being automatic.