Alexa Port Forwarding HA OS

I’ve been trying to connect to my Echo Dot v2 for hours. I’ve tried different ways. Port forwarding with Ubuntu (e.g. 80-> 60001). Every time I get “unable to start on …”. Sometimes it’s online but Alexa can’t find any devices. Now I have HA OS installed. On port 80 it is of course not possible … “unable …”. The hub is at least constantly “online” on port 60001.
How to forward port 80 to 60001 on HA OS?

After installing Nginx Proxy Manager, I was able to forward port 80 to 60001. But Alexe still doesn’t find any devices.
Any Ideas?


I don’t think reverse proxy is going to work with this component. They would need to add an option in the nodered config to also add the forwarded port so it can respond to the advertisement correctly. As it works now, even if it gets the discovery message, it is replying to the echo that it lives on 60001 which the echo won’t accept. It needs an “advertise port” option like the HA emulated_hue component has that you would also set to 80. You would need to modify the component’s js files or submit a feature request.

I ran the HA emulated hue with a reverse proxy for a while and it worked after I add the advertise port option but I got mixed results with my harmony so ended up moving it to port 80 directly. There are instructions on the HA emulated hue page on how to allow port 80 on linux. Not sure if it works with HA OS. Some older echos also will still accept non-80 ports, so if you have other echos you can try discovery from them. I still have one echo dot that works with any port.