Alexa-remote2 - stop to work after few days - Delete cookie file to get it back running


I’m using alexa-remote2 in NodeRed to control my Alexa (and not Nabu Casa)
I followed a video which explain step by step how to implement this and it worked fine.
But the problem is that after few days, my Alexa NodeRed flow stop to control my alexa device without any error message
I discovered that if I delete the Cookie file required by alexa-remote2 authentification and open again my NodeRed, the system ask me to connect again to the URL which allow to enter your credential (below)


If I do this, then eveything is back to normal until few days after where it stop again to run properly (same behaviour than above) , etc…
I tried 2 types of authentification (via cookie and via Proxy). In both case I have the same issue
Is one of you have an idea how to fix this ?


Nobody having an idea there ?

It appears to be a problem reported by others as well:

Someone reported that had better success when it’s connected to the Amazon US server.

I’m using alexa-remote2, it is connected to the Amazon US server, I don’t have the problem you are experiencing (deploy causes loss of authentication).

Hi Taras

OK will try the US version
On Alexa nodes, Do you connect with Cookie authentifications or with Proxy ?
Do you use the alexa Intitialise node or not ?

I use Proxy method.
I don’t use the Alexa Init node.