Alexa says "Device doesn't support that" but the app interface works fine

I think that this is most likely an Alexa problem and not HA but wanted to see if anyone else has had a similar experience

I have a couple of Philips Hue bulbs, model: LTW015
These are connected to Home Assistant using the Zigbee integration and a Nortek GoControl HUSBZB-1. I use the Home Assistant Cloud (Nabu Casa) integration to sync entities with Alexa.

This has all worked great for a long time. But, a few days ago, when I asked Alexa to change the brightness of one of them, Alexa responded that the device “doesn’t support that”. I tried brightness and color commands. Same response. I can only turn this light on and off but cannot change settings.

I went to the Alexa app and see that the settings are available. Using the app, I can change brightness or white balance. But voice commands will only allow me to turn it on or off.

I have tried:

  • Delete the device from Alexa and resync
  • Delete the device from Alexa and HA, then re-add to HA and resync.
  • Move the device to different Alexa groups or no groups at all
  • Changing the device name

Nothing seems to work and I cannot see anything different between bulb 1 and bulb 2.

Has anyone seen this before? I can’t find any way to determine why the Voice commands do not work but the app settings do.

I found a strange fix for this. In Alexa I created a group with the same name as the lamps that would not work and then added the lamp to that group. Now Alexa is able to execute commands other than on/off (dim, change color, etc. ).

If I remove the lamp from that group, Alexa can’t execute any commands except on/off.


I had the same problem, but for a different reason: I found I had an empty group with the same name as the device I was trying to control (pro-tip: You can create “groups” of 1 device; they function as aliases).

1 Like

I’m having the same issue, but I do not have home assistant. It all started with swapping out a hue ambiance bulb to complete my set of 4 colour bulbs. The newly substituted bulb wouldn’t respond to group commands in “Office” where I’d put it. To troubleshoot I deleted all of my lights and Office room from Hue/Alexa/Home Kit, power cycled, and added them all back from scratch.

Now “Office” doesn’t support any verbal form of Alexa command. A work around was to name the room “Office Lights”, now they all respond to group dimming/on/off/colour, but won’t allow verbal control of “Office 1-4” independently.

My issue is similar, but backwards. My bulbs/lights have only on & off, and these work fine individually in the App and with voice control. However they are in a group which works fine ONLY in the App. When I try to turn on the Group, Alexa says it does not support that. I have deleted the group and recreated it, but that does not help.

I don’t want to take device out, as it seems unlikely to help per above, and they bulbs up on a high ceiling, with no ground level switches!

I had the problem with Alexa when I asked her to turn on cabinet light, she would say
she didn’t support it. I went into Smart Things app & changed it from cabinet light to
Kitchen light…She responded & turned the light on. The same thing with "Living Room Lamp. I changed it from living room lamp to table lamp & it worked.

Late reply but in case anyone else is searching like me. I had this issue. Main Alexa account was linked on my partners phone. My account was linked and worked from the phone app but devices wouldn’t respond to voice until i’d done the linking procedure on her phone / account.

Hope this helps.

Even later reply, but in case anyone else ends up here……

When I told Alexa to turn on or off my “Dining Room Light”, she failed with “Dining Room doesn’t support that”, despite being the first such light that worked for years, and despite it working fine through HA dashboard and through Siri

I eventually checked my Alexa account and saw my other devices but that one was missing. So I went into the voice assistant menu of Home assistant and toggled to expose that entity off and back on. Now Alexa is happy again.

FYI- I installed two new Nest thermostats. One was named “Downstairs” and the other “Upstairs”. Downstairs worked finr, but Upstairs gave me the ‘Device Doesn’t Support That’ error.

Apparently, I had created a group named “Upstairs” in the app some years ago. I deleted the group and the upstairs thermostat now responds OK.

I had three Teckin smart plugs that I had named “unused,” “drawing room,” and “conservatory” in the SmartLife app. I had added all three plugs to the SmartLife platform so I could control them from the SmartLife app on my phone.

Initially, all three smart plugs were automatically added to Alexa as well. I was able to turn them on and off from within the SmartLife app without any issues. However, when I tried using Alexa voice commands like “Alexa, turn on conservatory” or “Alexa, turn off drawing room,” I would get an error saying “Device doesn’t support that.” Oddly though, the voice controls worked when I said “Alexa, turn on unused.”

After some trial and error, I realized the issue likely had to do with Alexa interpreting the names “conservatory” and “drawing room” as room names rather than device names. To fix this, I renamed the “conservatory” and “drawing room” plugs in the SmartLife app to non-room names. Once I did that, the Alexa voice controls started working properly.

In the end, avoiding names that Alexa might interpret as rooms when naming these SmartLife devices allowed the voice controls with Alexa to function correctly. Hopefully this helps anyone else who might run into a similar issue with device names not working properly with Alexa voice commands.