Alexa skill account linking - invalid redirect URI

I followed all the steps in “Amazon Alexa Smart Home Skill” (Amazon Alexa Smart Home Skill - Home Assistant), but when I try to link my Home Assistant account to my Alexa Skill in my Android Alexa app, after logging in to Home Assistant with my username and password I get the following message: “Error: Invalid redirect URI”. The same thing happens when I try it on my Kindle Fire Alexa app.

I did NOT enable the “Allow users to link their account to your skill from within your application or website” option because that the documentation says that “This will require a Redirect URI, which won’t work”, but still I get the above error. I also tried to enable this option and provide the redirect URI specified at the bottom of the account linking page according to my region - same result.

The documentation page mentions that the linking can also be done by using the Alexa Web-based app, but I couldn’t find any mention of skills on the Web app.

My HA installation is accessible from the outside using HTTPS port 443 (I forwarded it to 8123 in my router).

Any ideas?

Thsnks

3 Likes

I have the same problem …
anybody knows what to do ?

I had the same issue and since no one answered I will give you the answer

Based on this topic How to fix linking Alexa to HA using ngrok. It throws Error: invalid client id or redirect uri - #3 by adica

I also changed the ‘Your Client ID’ from https://layla.amazon.com to https://petinga.amazon.com
and now it works :slight_smile:

The reason why I choose laylay, because my Lambda is hosted in Ireland, which should be in the EU zone?
Anyway, it works, so I’m happy

1 Like

Awsome it worked! Thanks, but you have a type in your URL. It’s https://pitangui.amazon.com/