Alexa skill works via amazon website; Echo says there's a problem with skill's response


I just got me an Echo yesterday :slight_smile:
Out of curiosity I created a sample skill some time ago on amazon’s developer portal, following the steps outlined in the alexa component documentation.
My sample skill should just respond with a user’s location when asked.
On the HA side, I also added a notification action that is invoked everytime the intent is called.

So when I’m on and test the skill by typing in a question like “where is Sebastian”, after a few seconds I see the correct answer in the web interface and I also get the notification sent from HA that the intent has been triggered. So everything works as expected.

Now when I’m talking to the Echo “Alexa, where is Sebastian”, Alexa responds with “There’s a problem with the requested skill’s response” (I’m using Alexa in German language, but I think that’s the correct translation).
I also don’t get the notification message, so I think the intent was not triggered.

What am I missing?


Solved it. For the record: I’m running HA behind a reverse proxy with basic auth.
I disabled basic auth for HTTP requests starting with /api/alexa/* and now it works :slight_smile:


I’m having this exact same problem. I’m running Hassbian on a RPi3…how do I disable basic authentication for HTTP requests? Googled around a bit but still feeling lost.



this is what I have for Apache 2.4 (in the VirtualHost config):

<If "! -R ''">
	<If "! %{REQUEST_URI} -strcmatch '/api/alexa/*'">
		AuthType				Basic
		AuthName        Home-Assistant
		AuthUserFile		/etc/httpd/conf/htpasswd
			Require	user	user1 user2
				Include			/etc/httpd/conf.d/allowed_ips.acl

The outer <If>-clause is to enable authentication only for requests coming from non-local networks (i.e. everything except
The inner <If>-clause filters out URIs starting with /api/alexa/.

See for details.


Thanks Sebastian, I’ll look into this for Hassbian. What OS/platform are you running HA on?

It seems weird that none of this is in the documentation and presumably others got this to work?

I’m running the official HA Docker image on a Centos 7 host.