Alexa Smart Home Integration account linking issue

Hey All,

I have had the Alexa Smart Home Skill up and running for a few months now and everything was working fine.

I run HA on my own server, exposed to the internet on my own domain and has successfully setup the Account Linking so that I could login using my local HA Username and Password. I restricted the devices that were exposed to Smart Home to a number of switches and that worked well.

Last week, that all stopped working.

I think Amazon made some changes to their authentication, so I have set up 2FA as I was having issues with the Alexa Media Player integration. That is all good now.

Then I went to see if I could see my HA switches in the Alexa App (iOS) and they were not there. In fact ALL my devices (even non HA) were missing, as well as all my Routines. So I setup the integrations again, and set up Routines, but then went to add my ‘Your Skills’ for my developer ‘Home Assistant’ Smart Home Skill, but it was not visible in the ‘Your Skills’ list? Ended up having to re-save (without any config change) on the Alexa Developer console and it finally showed up.

S Now, on the Alex App, I add my own Home Assistant integration, and have to ‘Enable to Use’. Clicking this loads my HA Login/Authentication screen, but I don’t get any UserName and Password fields. I get a red error message that says ‘Error: Invalid client id or redirect url’.

I also get a norification in my HA Notification saying: Login attempt or request with invalid authentication from

I have not made any changes to my HA config, nor on my Amazon Alexa Skill config, so not sure what to do?

I tried removing the App and re logging in, but no change.

Anyone have any advice?

Thanks in Advance,


OK… Nevermind.

Seems Amazon had migrated my account from he US to Australia, so that effected my Smart Home. I had to chance the client_id to use the Japan client id. :man_facepalming:

But now I am also not getting my devices discovered… which I think was the same issue when setting it up in the past. I may have to move my lambda to another region.