Alexa Smart Home Skill - Alexa says unresponsive device but the action is completed

Hello,

I have followed the tutorial for integrating my home-assistant devices to Alexa: https://www.home-assistant.io/integrations/alexa.smart_home/#alexa-web-based-app

It seems to work properly, as my devices are correctly discovered by Alexa.

However, when I say to Alexa “Turn off the light”, Alexa answers “Sorry, the device is unresponsive”. But Alexa turns the light off correctly!

Why is Alexa returning this kind of message if the action is correctly done?

Thanks in advance!

Have you still got the original device-specific skill enabled in Alexa?

Hi Stiltjack!

Not all the devices that I have in home assistant, have an specific skill. For example, the device I was talking about is a Zwave dimmer.

The device is discovered by Alexa, and Alexa can control it by turning on/off. However, Alexa says that is unresponsive.

Regards

Haven’t had any experience with zwave, however I have found that once it’s linked with HA Alexa “discovers” hundreds of things - I have several wireless tags and because they contain multiple sensors Alexa regards each one as about eight devices. It’s a good idea to go through the list in the Alexa app and disable the ones you don’t need - you may find that you have duplicates.

Hello,

There are a lot of devices, that’s true. But this is not the problem that I am talking about. The problem is that Alexa doesn’t interact properly with the devices, even if they are correctly discovered.

I think that the problem is related with a time out in Alexa’s response, or in the device state change… But I don’t know how to solve it.

Regards,
Alex

Hi there,

Newbie here, installed HA last week and having the same issues. Works fine but always get the feedback from Alexa that device unresponsive.

It’s as if Alexa cannot read the status either as although light may turn on Alexa still says off.

Anyone else have issues? I also have one plug that although in HA will not be discovered by Alexa despite being one of several all via SmartLife. The rest are working fine.

Cheers,
Geoff

anyone get a fix for this?

I have the same issue… the device is discovered but it is not working properly. I can’t turn the lights on or off. When I select the device, instead of a power button, Alexa displays the device properties, as in this example:

I’m using the raspberry Pi with nginx and accessing the port 8443, since the 443 is blocked by my operator. Other than that, everything else is strictly the same as the Alexa integration tutorial.

Anyone knows what is going on or how to debug and discover the error?

I discovered my mistake… I used the example configuration provided by the tutorial to configure my Alexa entities:


In my case, I changed the locale and removed the client id and secret. I don’t know why, the variables endpoint and/or locale were causing the discovery devices process to block the devices capabilities:

Without capabilities, Alexa didn’t know how to trigger the actions I was asking for. After removing the unnecessary lines, everything worked fine.