Alexa Smart Home Stopped Working

A few days ago my Alexa Smart Home integration stopped working. I tried disabling and re-enabling the skill in the Alexa app and via the website and it will not re-link. When trying to link, I’m prompted for my HA login/password, it seems to accept it, but then gives me an error stating Unable to link Home Assistant to Alexa.

It seems like Alexa isn’t getting the token or something. There is no associated token entry in the profile section of the HA app. There aren’t any useful entries the HA log either. Any ideas? There’s no way it’s related to the Let’s Encrypt root CA expiration from a few days ago, right? I only mention because I hadn’t changed anything or even restarted HA when the problem first presented itself. Thanks!

it’s most likely related to your certs, restart nginx or ddns or whatever you’re using.

Thank you. I’m running LSIO’s SWAG container and restarted that to no avail. I’m also utilizing Cloudflare’s Argo tunnels, but hadn’t had a problem doing that until last week.

The problem ended up being Cloudflare’s firewall services that I have in front of the domain. The default “Bot Fight Mode” started blocking the Alexa Smart Home connection. I had to disable this setting under Firewall->Bots.

As far as I know, I always had this enabled. I hadn’t made any changes that caused it.