Alexa TTS Seems to be working, but

I’ve just installed the Alexa Media Player integration. Went through the 2 step authentication process, etc.

So I now have 125 entities under the Alexa Media Play Integration. I think I’m on the right track.

If I open the Alexa Media Player for my Lounge show, it tells me it’s on Standby. If I type in “Hello” in the Text to speak box and press the button, nothing happens.

Can someone point me in the right direction, please?

The alexa_media_player wiki said it does not support Media Player UI for TTS.

You can find examples in the Notification Component link above.

This is what I have done:

In developer tools > services
notify.alexa_media (Chosen from the dropdown)

Service data as below

message: Hello
  type: tts
  - media_player.lounge

Still get nothing.

I chose from drop down my alexa echo:


Service data:
{data: {type: "announce"}, message: "testing testing"}

Still no joy :frowning:

Chose notify.alexa_media_lounge from the drop down and pasted your service data in. Still nothing. Tried removing everything and starting from scratch. Still nothing.

I tried all my echo’s with the above service data, both type: “tts” and “announce” worked (announce plays a tone before the spoken text).
Sorry, wasn’t helpful, happy holidays.

1 Like

Ok, thank you. Back to the drawing board :slight_smile: