Alexa with Emulated Hue and Insteon

I was going to try using the local phone alexa app with the emulated hue. But I see I already had add the insteon devices which no longer work. How do I get rid of the whole of Insteon from the Alexa app on Android? I deleted each device individually, but I think Alexa is still keeping some reference somewhere and sees the devices to add them again.

When I tried to setup the Hue, it took me to web to find hub and said it couldn’t find it. I presume because it was trying to get access to the Hue from outside my lan. I don’t have that setup yet. Is there a way to get it to accept it without having to be on the web?

This is all stored in the alexa device, how you get to it has no impact on the alexa device. Alexa devices cache the configuration. All of them do this. You have to remove the app and restart every single one of your alexa devices.

No you’re not understanding how it works. Emulated hue emulates a hue hub locally. It makes your network think you have a hue hub when you really just have home assistant. If you can’t find it, that means you didn’t set up emulated hue correctly. Emulated hue does not connect to anything, it’s so things can connect to HA. Those things that connect to HA think they are connecting to a hue bridge.

I have NO Alexa device. So there is no cached configuration on a device. The Alexa app was already configured to interact with the Insteon hub in the past, but now fails because Insteon went belly up. That is why I want to remove the skill of Insteon from Alexa app.

I do understand how the emulated hue hub works. I set it up and already was able to connect my Logitech hub to the emulated hue hub. Now my remote can trigger Home Assistant devices through the emulated hue hub.

Unlike the Logitech system which recognized the hue hub emulation on the local network, Alexa takes me to a Philips hue web page and tries to contact the hue hub from there. Which apparently doesn’t work because the web page isn’t local. Or because I don’t own an Alexa device. Or for whatever reason the Alexa app can’t see the hue emulated hub.

So I’m basically asking if anyone else has successfully gotten Alexa phone app to work with the emulated hub locally with no internet involved. (Like I used to use the app with the Insteon hub locally)

If I recall correctly, you have to connect to the hue bridge by just searching for default devices, don’t specify hue.

I’ll try that again, but I think I tried it first and it didn’t find it. Wish me luck.

Also from what I remember, you need to have port 80 specified or open. It’s been a long time since I set up emulated hue. But getting it to work with Logitech and Alexa at the same time was a PITA if I recall correctly.

Emulated hue default is port 8300. Which must be open as the logitech worked with it no problem.
Logitech was a breeze.

Yes, the issues were always getting both to work together.

Any clues as to how to get Alexa to stop listing out the Insteon devices that can no longer work?

They are cached somewhere, if you don’t have an alexa device, they are cached on your phone.

I assume that even if they are cached, once alexa starts up again, it will find them again. But maybe not. I’ll try clearing the app cache on the phone. (I would have thought one could just tell Alexa to forget the Insteon devices, oh well)

It should not. Alexa is a pain with cached info. Typically, you have to delete the cache and reset the device. I have no idea how this works on the phone, however I’d follow the same path.

I give up. I cleared everything and loaded the app which made me go through the setup again with voice recognition (Insteon IS gone). Then, if I tried to get it to find the hub (v1 or v2), it wouldn’t find it, or it would take me to the web to the alexa/amazon account and try to locate the hub and fail.

If I say to use a skill and choose a philips light, it takes me to the web again.

I deleted Amazon Alexa from the phone. Maybe if I join Nabu Casa, I’ll try again. Thanks anyway.

Without a doubt, emulated hue has to be on port 80 for it to work with alexa.

See the examples in emulated_hue’s documentation

# Amazon Echo example configuration.yaml entry
  listen_port: 80
  # Amazon Echo/Alexa stopped working on different ports. Search for "Philips Hue Bridge V1 (round)" in the Alexa App to discover devices.

Also from that doc:

listen_port integer (optional, default: 8300)

The port the Hue bridge API web server will run on. This can be any free port on your system. However, all new **Alexa devices** require listen_port: 80. See `setcap` note below if this is set below `1024` when Home Assistant is ran as a non-root user.

Again, that is talking about Alexa DEVICES. So that is why I ignored that part. And I decided to stick to default port 8300. Especially since it connected with no problem in Logitech MyHarmony app.

And then they said:

Home Assistant Core
An additional step is required to run Home Assistant as a non-root user and use port 80.

On Linux systems (Ubuntu, Debian, etc) execute the following command to allow emulated_hue to use port 80 as a non-root user:

sudo setcap 'cap_net_bind_service=+ep' /srv/homeassistant/homeassistant_venv/bin/python3

And as soon as I saw LInux, I stopped. I don’t want to get into command lines on an OS that I don’t know well.

Maybe I’ll look into it, but I’ll probably just use the Nabu Casa service.

Or, maybe I’ll just look at the google assistant and forget alexa.

The alexa app being used as an alexa is an alexa device. They “should” run all the same code. Only the developers of the app will know that. Either way, it’s safe to assume your phone = alexa device.

I spent this much time already, I thought I’d go ahead and try the port 80. Of course, that screwed the Logitech hub which couldn’t find the Hue anymore. And doesn’t have the opportunity to tell it what port to use. Nothing is ever easy.

I also am guessing that if I wanted to set up a web server on the Synology box that is running HA, there would probably be a conflict there.

That’s why I mentioned:

The both I’m referring to is Logitech and Alexa devices.

I tried some port routing tricks, but that didn’t work either. I officially give up.

I went the Nabu Casa route and it is all working now. NO ports as far as I can tell (other than maybe the HA one).