All config lost after updating


I switched from home assistant to - (No matter what whoever says, it is confusing to distinguish the two, IMO there should be just one thing) - In hope that all updates etc. would be seemless, just click and done.

I run in rPi, i think 2B, in virtual machine. After updating hass Lovelace stopped working and my sensors don’t show any data.
There is no error when i click on “(i)” icon in the log.

I have only two plugins - mosquito and configurator. In configurator i can see that both configuration.yaml and lovelace ui config.

All i have in hass are 5 sonoff pow r2 running tasmota. So i have added 5 switches and 5 sensors.

In mosquito I can see that sonoff-tasmotas have logged in.

So what is the issue - after update - I don’t have lovelace ui - it just redirects me to default status view - in status view I can see all sensors and switches I had configured, but it does not display states of the switches and no data from the sensors.

I really don’t know what do now - I have config that worked, it seems that it should all be working, but it is not.

BTW is there any way to get original firmware to sonoff pow r2 - i only wanted multiuser (and direct web) control of the switches and ideally web statistics of power consumption, but I think having hass for this is too much hustle for me. I don’t want to be rude to developers or anything, just asking :slight_smile: I think default firmware even has monthly power consumption statistics while sonoff tasmota does not. I know this is not directly hass issue, but it is quite related.

Maybe espurna works better with mqtt?
Or would you recommend some software that is better for my needs then hass?

I agree.

I disagree. There just needs to be a clear distinction between them.

in a virtual machine? how?

Updated from a version older than 0.84.x? Did you read the release notes?

Well no, but reading it now, i see the section about lovelace-ui, but still, I would like to make sensors and switches work first and focus on the lovelace.

So how do you know they aren’t working if you don’t have a working front end?

I do have the basic/default one with all the circles at the top etc.

In system > integrations > Mosquitto I get message “This integration has no devices.” - but i think i got it even when it worked before.

I get that too and my MQTT works just fine

Unfortunately removing mosquitto integration and adding it added kinda fixed it, but it added all switches again in discovery mode, ignoring my defined switches. Funnily it added all sonoff switches 2 times, in mosquito integration it is showing only one switch, but in home assistant there are two, why only second one is correct.

I’m going to try to find a way to revert to original firmware. If not possible, then I will look for some alternative to Hass. Hass is just too unstable for me, whether it is my needs or my environment or maybe it just is.

If you use defining switches in config yaml then it normally won’t pick up any in the integration.
If you are running Tasmota 6.4.x, the topic/prefix order has changed so if you use integration+discovery they would be detected again.

I only use MQTT discovery and the inbuilt broker and the integration and they aren’t duplicated.

Oh also… if you remove the integration you need to restart. I have also found if you add the integration, it shows no devices until (you guessed it) you restart.

1 Like

I think it is now possible because of how lovelace now works, to use discovered devices too.

Also I noticed this tool for original firmware that would be probably most stable way to go and I could keep original power usage statistics too.

Now to find a way to install original firmware on these boxes when i’m at the location, preferably over the air. But I was not able to even backup original firmware, so far no luck googling.

I doubt it would be better and would be slower anyway. I would never go back to EWeLink from Tasmota and doubt you will find the firmware anywhere anyway.

I am a fan of MQTT discovery. (And it has nothing to do with Lovelace BTW) It just works. I deleted all the MQTT config from config yaml inc broker, just use the Mosquito addon and the integration and it just works.

1 Like

I’m all for open standards too, it is shame mqtt is not part of the official firmware, but for me reality is as described :slight_smile:

add this to your configuration.yaml:

  mode: yaml

and go from there…

See? I was hinting at that in my first comment, and expected the OP to read it…

1 Like

yeah, i saw that. i also saw that it wasn’t happening and going down a different rabbit hole so i figured i’d be more explicit.

you can lead a horse to water…:slightly_smiling_face:

1 Like

if the horse drowns, it’s on him

1 Like

While in reality only reply from DavidFW1960 was helpful.

While it is weird, that before updateting hass everything worked even with updated tasmotas.