All controls (switches, shutters, etc) stop working after a while

After the latest updates for Core and supervisor (not sure if it is a coincidence or the root cause), all my zwave controls stop working after a while (after a reboot).

The zwave network itself seems to be working, as I still get regular data packets from the energy monitor meter. Nonetheless, any switch (for lights, for example) does not do anything.

I have to reboot in order to get full control of my house again, but that does not last for long (not sure how long does it take until the controls are unresponsive).

I know it is a long shot from this description, but is anyone experiencing the same problem? Any clues of what could be causing this?

FYI: I’m using the zwavejs2mqtt addon

1 Like

I too am having this issue. Would love any insights.

Apologies for the brain dump - if I restart the WS Server from ZWAVE JS to MQTT then the integration works again with control of lights etc.

I wonder if the issue is the latest ZWAVE JS to MQTT rather than home assistant itself.

Yep, the same is happening with my home assistant installation.
I just restarted the addon and it everything is working without having to restart Home Assistant or the RPI.
I guess this is something related to the addon itself (or to some issue that was added on the latest updates of the core or supervisor).

I still did not move to the official zwaveJS integration as not only I did not want to go through all the entities to name them (I think that will be lost as soon as I switch the zwaveJS in use), but also I do not want to loose the webUI from zwavejs2mqtt. Nonetheless, I prefer stability over everything else, so maybe I’ll get my hands on this weekend.

There appears to be a bug in the underlying zwavejs server update. Zwavejs2mqtt is built on zwavejs and includes it, so I don’t think switching between the two will fix this.

After I updated my zwavejs2mqtt, which bumped zwavejs to version to 8.8.2, my zwave network crashed every night, and restarting zwavejs2mqtt was the only way to fix it. I run the docker version of zwavejs2mqtt, but the zwavejs2mqtt addon version was also updated recently. Zwavejs had a major code refactor/rewrite which appears to have created the issue. See release notes below:

I rolled back zwavejs2mqtt to the older version in docker and the problem went away. Unfortunately if you use the addon version, your only option to roll back is to restore an old snapshot.

The developers of zwavejs are aware of the issue and are working on a fix. Here’s related posts on github


Thanks Tim for the update on this.

Let’s hope there are news about this anytime soon. I had the addon set with autoupdate, so unfortunately I don’t have a way to revert to the previous version (in this case snapshots are not created automatically).

yes thanks for the update.

I’m having the same issue. The Z-Wave network first slows down significantly (often taking 3-10 seconds to toggle a device) to being totally unresponsive until I reload the add-in or restart HA. I’ve been tying to diagnose and fix this so I’m glad I ran across this thread so I know that it may be fixed soon!

Not sure if this will go anywhere, but I created a feature request post to at least implement the ability to downgrade an addon if something like this happens. Click below to vote for it if you agree

ZwaveJS released a new version 8.8.3 that rolled back the code changes to the outgoing message handling that created the bug mentioned above.

This zwavejs update has also been pulled into Zwavejs2MQTT version 6.0.3

I can confirm all is working OK so far in my docker version of zwavejs2mqtt. For anyone running the addon version of zwavejs2mqtt, you will need to wait until these updates make its way into that - you can track that progress on the addon Github page below

I submitted an issue to hopefully move the addon update along

Update- the zwavejs2mqtt addon has been updated. Installing the latest version of the addon should fix these issues.

Im still having issues

2021-12-04 16:19:02.587 DEBUG SOCKET: New connection 4F4fLBmn_Mmoc-VVAAAN
2021-12-04 16:19:02.700 INFO APP: GET /api/auth-enabled 304 5.976 ms - -
2021-12-04 16:19:02.712 DEBUG SOCKET: Event INITED emitted to 4F4fLBmn_Mmoc-VVAAAN
2021-12-04 16:19:15.946 DEBUG SOCKET: Event ZWAVE_API emitted to Ynyssnc0z9k1hVcXAAAL
2021-12-04 16:19:15.950 INFO ZWAVE: Calling api writeValue with args: [
{ nodeId: 2, commandClass: 37, endpoint: 0, property: 'targetValue' },
[length]: 3
2021-12-04 16:19:15.951 INFO ZWAVE: Writing true to 2-37-0-targetValue
2021-12-04 16:19:20.668 ERROR ZWAVE: Error while writing true on 2-37-0-targetValue: Failed to send the message after 3 attempts (ZW0202)
2021-12-04 16:19:20.672 ERROR ZWAVE: Unable to write true on 2-37-0-targetValue

Maybe it’s a different issue. It appears to just fail to communicate the command to Node 2. A few questions to hopefully come up with a solution:

Any improvement with the update? Ie is everything crashing or is it just sometimes a command doesn’t go through, or takes awhile? Also, was everything fine before these updates, or did you have some problems before?

What is node 2 exactly (manufacturer/model)?

Can you do a “heal node” ( not entire network heal) of just node 2? Any improvement with the healing of that node? Did it heal ok or error?

How far away from the controller is node 2?

Also it looks like these are just the zwavejs2mqtt logs. There are 2 sets of logs. Can you post the underlying zwavejs server logs? See instructions below for getting those.

Funny enough, after upgrading to this month’s HASSIO release, as well as upgrading the operating system, I’m getting again the same odd behavior (zwave devices that send data get it right, but all controls are unresponsive).
I’m now updating zwave2mqtt to a minor version that was released today hoping that it will solve this once more (I cannot tell for sure immediately, as now the controls get unresponsive after nearly 24h).

Jumping on this wagon. A couple of weeks ago, I updated to 0.31 and after a while zwave became very slow. Reverted to 0.30 and things are great. Last night, went to 0.32.1 and everything slowed down again. Unfortunately, I can’t update home assistant without updating z-wave too. So it looks like I’m stuck where I am, home assistant 2021.11.5 and Z-Wave JS to MQTT 0.30.0.

Well, I tried to revert back to the previous version of zwavejs2mqtt from a recent backup that I created a few days ago just to find that when I restore it, the addon fails to start because the “addon image does not exist”. Too bad we cannot trust the backup system.

And in the meantime I have to restart my host every 3 hour in order to be able to use any ZWave device… I mean, once again devices that broadcast zwave messages (such as the energy meter) get their data transmitted, but devices that get input (such as a switch or a shutter controller) stop working completely.

I have the latest version of everything (HASSIO, operating system and zwavejs2mqtt).

Well, after reverting to hassio 2021.11.x the problem remains, so I guess this is once again a problem related to the add-on.
Mental reminder: start doing a full backup of the system before updating the add-on, as partial backups do not seem to do the trick to restore a previous version.

I use the Google Drive Backup and Samba Backup addons. Do a couple full backups per week. If you’re not doing that and don’t have the local storage, maybe the google one would be a good option.

In any case, I’m still holding out. Hoping I can find something that says the issue is resolved.

EDIT: Fingers crossed, it looks like this may be fixed. Zwavejs2mqtt addon 0.32.2 updates zwavejs2mqtt to 6.2.0. That bumps zwavejs to 8.9.1 and I believe the bug was fixed in 8.9.0. We’ll see… This all assumes I’m reading the notes correctly.

EDIT 2: Initially had a bit of a hiccup with slow response times. Seems to be working fine though.

1 Like

I too am have this problem. I’m on zwavejs2mqtt 6.1.1 and zwave js 8.9.0-beta.1

I know it’s a websocket crash because my zwavejs2mqtt runs in a debian lxc container and my ha core venv runs in a separate container.

I can systmctl status both programs and they are u0 and running. When I check the logs on HA it will kick an error it can’t reach the server.

However if I leave HA amd reboot the zwavejs2mqtt lxc everything functions again for a time.

I am having this problem, as well. I had originally used the zwave JS server and had this issue, so I moved to the MQTT version and the problem persists.

zwavejs2mqtt: 6.13.0
zwave-js: 9.5.0

I even upgraded my HUSBZB-1 to the latest firmware I could find (on the GitHub), with no change. I have separated my stick with a USB extension (designed for RF), just in case that was an issue.

System will run fine for a while, and then HA doesn’t seem to get any messages from MQTT. I then restart MQTT and all if fine.

In my case the problem is long gone.
If I’m not mistaken it was solved after one zwavejs2mqtt update.