All in one installer and Hassbian Not WORKING! HELP!

Run the following command:
$ curl -O && sudo chown pi:pi && bash

and i get this! help :frowning:

What if you try /bin/bash instead?

how? I am really new into this so please help me :frowning:

curl -O && sudo chown pi:pi && /bin/bash

how about the hassbian disk image? why doesn’t work outside of the box?

I’m not using hassbian, so don’t know.

You haven’t said anything more about the Hassbian install than that it doesn’t work, so it’s impossible for anybody to say why it’s not working for you.

Your problem with the all in one installer however is because you included the $ at the start. Remove that and it should work fine.

1 Like

i already installed the hassbian in the raspberry pi. It prompts me to change my password and i did. and after that. nothing happens. How do i know if it is done or what?

Generally speaking, you don’t get positive status messages from linux command lines. If you didn’t get an error, then the password was changed. Obviously you can test this by trying to log in with the new password :wink:

1 Like

Its likely because you copied it and pasted. Remove the “$” from the begining of the line. It works fine, I just used it.

1 Like

thank you for the wonderful response. I preferred the All in one installer :slight_smile: Now it works thanks guys now i need to learn how to configure it any good tutorials?

There’s the documentation section of the site, along with the working examples posted here in the Share your Projects section.

Hi - I’m new to Home Assistant and Pi. I’m running into an issue with AiO on Pixi. I tried the suggestions above with no luck. The below are the few lines of text from SSH before Pi crashes and reboots while running the AiO script. The last line appears to be culprit and related to Python. I checked and Python 3.4.2 appears to be installed.

Any help would be appreciated. Thanks in advance!


[localhost] sudo: ldconfig
[localhost] sudo: ln -s /usr/local/lib/python3.4/dist-packages/cec /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages
[localhost] out: ln: failed to create symbolic link ‘/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/cec’: File exists
[localhost] out:

> Warning: sudo() received nonzero return code 1 while executing ‘ln -s /usr/local/lib/python3.4/dist-packages/cec /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages’!

If the Pi is crashing, then it suggests either you’ve got an underpowered power supply (or possibly a borderline supply with a too thin USB cable), or faulty hardware (including possibly a faulty SD card). First step is to switch the power supply for a known good, quality, 2A supply with a good quality cable.

Thanks Tinkerer. I believe I have good quality SD/PU (i.e. 2) but will try swapping SD. What leads me to believe it is not a hardware issue is that the Pi crashes on the exact same command line in the script (6 times in a row to be exact.). See below. Thoughts?

Warning: sudo() received nonzero return code 1 while executing ‘ln -s /usr/local/lib/python3.4/dist-packages/cec /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages’!

Thanks again!

Full on crashes are only caused by:

  • Hardware faults
  • Kernel level problems
  • Running out of RAM

It’s not possible for a user mode program to cause a system to crash, outside of possibly triggering the last of the above.

Now, you’re sure it’s a crash, and not the reboot that’s performed automatically at the end of the install? You’ve checked to see if you’ve got a working HA install?

1 Like

Well Tinkerer, now I really do feel like an idiot. Looks like you are spot on. Wasn’t crashing just rebooting after the install. Seems to be working fine. Many thanks for your help and patience!