All Lights somehow paired to motion sensor

Something weird happened today. Somehow, one of my motion sensors has paired directly with “all devices on” and “all devices off”. If I walk in front of the motion sensor, every single Zwave device in the house comes on. When motion stops, everything turns back off.

What’s the best way to handle this? Do I just remove and re-add the motion sensor, or is there a cleaner way to fix?

Also - any guess at how such a thing happens? I did upgrade to 0.43.0 today.

You’ve got the group associations messed up in ozw. Did you happen to play in those settings?

I didn’t open OZWC or try to make configuration changes from the Zwave manager in HA.

I’m still having issues with this this morning. With Home Assistant turned off, whenever my motion sees activity, all lights come on. I tried adjusting things in OZWC using the “group” setting, but that didn’t help.

If I look at my zwcfg*.xml, for that node, I see:

<CommandClass id="133" name="COMMAND_CLASS_ASSOCIATION" version="1" request_flags="4" innif="true">
		<Instance index="1" />
		<Associations num_groups="1">
				<Group index="1" max_associations="5" label="Basic on/off group for detecting movements" auto="true">
						<Node id="1" />
						<Node id="255" />

I suspect that the “255” node is my issue. I don’t see this node in my other (same brand) motion sensors.

Manually editing the XML doesn’t do anything (IIRC, the XML is cached from the controller - it’s not applied to it).

I can’t find an interface to remove this association.

I’v tentatively fixed this with the Zensys app that Aeotec suggested I download. It looks like my Zstick somehow got out of SUC mode. I think it might’ve gotten into SIS and let the motion sensor add the nodes to itself.

Regardless, the Zensys app is a pain to use, but I figured out how to remove an association and removed the “255” association, leaving the “1”.

Sorry been overloaded as work. OZW control panel will let you play with the group associations. You can reset them. 1 to 255 means all nodes which would explain your problems.

I tried OZW first. There was no way to remove the node 255 because OZW only gives you options from the existing nodes on your network. Zensys let me view associations on the motion sensor and remove the 255 association.


I am new to Home Assistant.

I had exactly the same issue with my “Aeon Labs Multisensor 6 - Z-Wave Plus” and the “Z-Wave TKB TZ69E Wall Plug Switch/Meter - GEN5 - UK”.

Every time the motion was detected the switch turned on and when no motion detected switch turned off. I reinstalled HA but still the same problem.

I reset my Z-Stick Gen 5 yesterday and re-added the motion sensor and the switch. Now everything is fine.

I was going mad for 2 weeks. I hope this helps.

I’ve got ~40 Zwave devices, so I was wary of a reset. Glad that Zensys fixed things.

So glad you posted this, @ih8gates! I’m having the exact same issue that seemingly cropped up out of nowhere and it’s driving me crazy.

I also see the <Node id="255" /> entry in my zwcfg*.xml associated with the problematic motion sensor. However, I can’t figure how to remove the 255 entry using the byzantine Zensys interface. Could you share how you managed to accomplish it?

Ug. It’s been a couple of months, so I can’t remember exactly. I recall that it was non-obvious. I’m pretty sure that it mostly involved the associations tab in the upper-right corner of the Zensys interface.

Do you have open zwave control panel?

Yes but I didn’t see a way to change the group association. I ended up removing and re-adding the sensor. Not ideal but it worked. If anyone has any idea why this happens and how to avoid it in the future, I’d really appreciate the information!

OZCP wouldn’t fix this for me. Since it’ll only remove associations that it can list, it didn’t list “255” or “all”. I even tried hand-editing the HTML via dev tools in my browser. Zensys showed an association with my motion sensor and “all” that I was able to remove.

Guys did anyone find a fix for this?

It’s covered in the documentation these days.

1 Like

@Tinkerer thank you, I’ll give it ago. It talks about “zwave.change_association” do I need to create that file in /config ??

That’s a service, that you use in the Services menu under the Developer tools heading.

1 Like