Allow external dir not working for Alpine, Pi4, Docker

Home assistant

I am running on a Pi 4, Alpine os, Docker container

I am trying to save smapshots to directory “homeassistant/media”

This should be simple. This product seems very unorganized. I have spent weeks trying to google and look for solutions but none work. I think my indentation in the yaml is correct. HELP!!!

Error when running save smapshot from camera


The location is correct. I just don’t have access. The directory has “chmod 777” applied

My configuration yml is below


When I check the configuration I get the message below

What am I doing wrong?

There is no top-level


is /homeassistant the directory you mapped your /config to in Docker ?

I have no idea. I am new to Docker and know nothing about it. Sorry to be so new.
How would I tell? When I log into Alpine /homeassistant isn’t there. I get root, home, etc and others. From the GUI “homeassistant” is the lowest I can go in the file browser. Hope that helps.

What did you replace


with ?

docker run -d \
  --name homeassistant \
  --privileged \
  --restart=unless-stopped \
  -v /PATH_TO_YOUR_CONFIG:/config \
  -v /run/dbus:/run/dbus:ro \
  --network=host \

I didn’t change anything. So it is whatever the image was setup with.
I tried to run "docker run -d " and got a “>” and don’t know what to do next.
I tried to run "docker run -v " and it wanted an argument.

if there is a command I can run to answer your question please let me know.

Thanks for working with me!!!

each docker run ended with a backslash which didn’t print in the above post

found etc/docker/daemon.json
“data-root”: “/mnt/data/docker”

does that help?

More information:

docker config

List of directories at /mnt/data/docker