Alternative way of running HassOS (full OS) on FreeNAS (without iocage or Docker)

I suggest to retry the dd command on a fresh zvol (if there would have been errors then they would have shown here). It depends on the disks speed, but it would take several minutes until completion. Can you check the size of the img file?

Also, you might want to delete the last printscreen from your post.

Since the start of the Covid I’m working from home so I completely removed the external access for HA.

Anyway, using the HA vm on TN doesn’t add specificity to external access so you could look for other topics that refer to Nginx/Traefik.

Been trying to do this on TrueNAS-12.0-U8.1. I have used the generic x86 image and have tried the converted image method from the original guide. Issue is I keep getting Boot Failed. EFI Misc Device or Boot Failed. EFI Hard drive.

I have no idea what I am missing - anyone else had this issue?

EDIT - Worth adding that if I add the generic or converted VDI image as a raw file it boots fine into the image file so I know the images are all good

Ok problem solved, the issue was my dd command my output file was wrong i pointed it to mnt/… not /dev…

Hi. After upgrading HA operating system to 8.5 (from 7.6), the VM doesn’t start. Is this documented?

It works. Sorry for the noise. I only had to restart the VM from TrueNAS. I got confused because other upgrades went smoothly without needing to force a reboot.

Coming soon to VMs on TrueNAS SCALE… USB passthrough!

1 Like

Probably the way to go is with SCALE since bhyve is not fully suitable for VMs.

Lets vote on it!


VBoxManage clonehd source/hassos_vm.vdi destination/hassos_vm.img --format raw

my 1gb VDI file chaned to a 32gb IMG file.
Is that normal?

Yes, that is the current size of the image.

oh, okay, thanks, need to order bigger drives

Wait. Why you would need larger drives?

my actual vm drives has only 20gig space free, ^^

I’ve been trying this for a couple hours. When copying to dev using the web shell, running as root I get the following output:
dd /dev/zvol/bulwark/haos-chars: Operation not supported
where chars is the random set of characters assigned to my vm zvol.
Any help with sorting this out appreciated

It appears the path for the zvol was incorrectly typed. Can you check what you get when running ls -al /dev/zvol/bulwark ?

Amazing the power of the ls -al command - showed that I was missing the dataset in the path. I appreciate you Petricia! Where do I send you a tip for a coffee?

The path formatting was /dev/zvol/pool_name/dataset_name/zvol_name if that helps anyone else resolve issues like this.

I’m sure you’ll be able to do a good deed for someone nearby :slightly_smiling_face:

Hahaha, I’ll do my best.

So update on this, as soon as I got it to ‘work’ it couldn’t detect the root device. This was because I had used VirtIO as the disk instead of AHCI when creating the VM. As soon as I set the disk to ACHI, the NIC to use the hardware adapter, and created a DHCP reservation in my router, it worked like a charm and took all of 5 minutes to get to run.

Thanks again Petricia for your great guide!

I started a new thread in the community guides section focused on TrueNAS SCALE.

Feedback and contributions are welcome.