Am i doing something wrong

I have made a sleeptimer in node red. You can indicate what time the TV should turn off using an input_datetime or you can say after how many minutes the TV should turn off using an input_number. The timer works but there is something strange.
When I set the timer to 1:00 am I see the following.
Screenshot 2022-11-30 at 17-09-02 Node-RED – Home Assistant
The time under the current state node only shows the minutes and seconds. Not the hour.

Thank you very much Hans

I believe your timezone is incorrect.
What does a debug node say?

Hello Hellis81,
The timezone is correct.
The debug note says:Screenshot 2022-12-01 at 07-25-33 Node-RED – Home Assistant
Screenshot 2022-12-01 at 07-25-59 Node-RED – Home Assistant
Switch off at the correct time thouh.

Greetings Hans

Maybe it goes wrong in the previous node, can you share the whole flow?

Hello aceindy this is the whole flow, except a inject node every minute to start.

Hmm…now that you mentio it…mine doesn’t even show the time at all…
(wich doesn’t really bother me, but it is weird your is different)

Maybe the output properties are different?

Why not just use the time node?

Yeah, that is why I asked for the whole flow, so I can paste it, and see what’s wrong :stuck_out_tongue:


[{"id":"daff13bb.15281","type":"api-current-state","z":"480e4fbb.d7002","name":"Already On?","server":"37d68302.2aabcc","version":3,"outputs":2,"halt_if":"on","halt_if_type":"str","halt_if_compare":"is","entity_id":"light.light_hallway_upstairs","state_type":"str","blockInputOverrides":false,"outputProperties":[{"property":"payload","propertyType":"msg","value":"","valueType":"entityState"},{"property":"data","propertyType":"msg","value":"","valueType":"entity"}],"for":0,"forType":"num","forUnits":"minutes","x":290,"y":120,"wires":[["d67976c3.140b78"],["d138811.3e1c58"]]},{"id":"37d68302.2aabcc","type":"server","name":"Home Assistant","version":5,"rejectUnauthorizedCerts":true,"ha_boolean":"y|yes|true|on|home|open","connectionDelay":true,"cacheJson":true,"heartbeat":false,"heartbeatInterval":30,"areaSelector":"friendlyName","deviceSelector":"friendlyName","entitySelector":"friendlyName","statusSeparator":"at: ","statusYear":"hidden","statusMonth":"short","statusDay":"numeric","statusHourCycle":"h23","statusTimeFormat":"h:m","enableGlobalContextStore":true}]

Hello aceindy,
Jou check if a device is on. So no time to be used by your current state node.
My currend state node uses the Value of input_datetime.time_beneden. this is a time. So it can (and does) display a time. Only its wrong.

Hello Hellis81.
In a time node, I don’t know how to enter a number.
Now whenever I want to change the delay I can change the number of minutes and voila.
Same when I set a time. I can easily change that on the dashboard.
I don’t think the time node offers this option.

Maybe my problem is just a minor bug

Greetings Hans

i don’t think it is wrong, but maybe truncated?
it only shows mm:ss and not hh:mm:ss :wink:

If you are using a input datetime then the time node will trigger at that time.

Thank you.