Amcrest ASH21 connection timeout

Has anyone gotten the Amcrest ASH21 indoor PTZ camera working with HomeAssistant? I have two AD110 doorbell cameras, which work really well. The ASH21 works with the same Amcrest SmartHome app, but I can’t seem to get it to connect to HomeAssistant.

It’s connected using WiFi (not ethernet) and it has a static IP assigned to it. I’ve got it set up using the same connection settings as my AD110 cameras, which looks something like this:

amcrest:
  - host: 192.168.1.116
    name: "PTZCam"
    username: !secret amcrest_username
    password: !secret amcrest_password
    scan_interval: 1
    stream_source: rtsp
    binary_sensors:
      - motion_detected
      - online
    sensors:
      - sdcard

In the logs, it’s showing a CommError, but digging in it’s getting a connection timeout. I noticed these seem to be kind of weird, because in the app it only shows the hardwired connection’s MAC address, and it’s showing the wrong IP address (even though I can see it’s connected correctly via WiFi). Is it possible this would only work with HomeAssistant if using ethernet?

1 Like

I am having trouble getting it set up too. I don’t think you’ll be able to use the amcrest integration on this camera specifically since they disabled the http interface. You should be able to hook it up to a generic camera with RTSP via the instructions here: How To Setup a Camera In Blue Iris with RTSP Support (ASH21) – Amcrest

But I’m having trouble even getting that working. I think it’s just kind of a shitty camera sadly.

I’m also having the same problem where it is showing the wrong IP address in the app, I can see on my router it’s a different one.