Amcrest camera making high number of DNS queries for

I was wondering if anyone else has seen an issue where your Amcrest camera is making a large amount of DNS queries to

I never used any Amcrest cloud services. I have no plan to.

Anyone know how to fix this and stop it from querying DNS so much?

It is on top of my Pihole Top Blocked Domains by an order of magnitude. I also blocked the cam’s static ip access to the internet.

EDIT: Even after upgrading to the latest firmware (3-19-2001) it is still phoning home. In fact I think it got worse – seeing over 30k DNS requests in a 24 hour period in my Pihole logs. Insane.

Solution: In Setup under Network, use Static settings and put in an invalid DNS address.

Disable P2P

Another user disable P2P and only after it was allowed to connect to that address did it stop. If that address was blocked they say it continue to try

1 Like

Since, Sept 9th till today, I have 38 queries to What do you consider to be, too many. Oh, and I have 6 Am Cam, 1- AD110 Doorbell v1, 2 - IP2M-841B-v3, 3 IP2M-841B-v1

1 Like

I have an Amcrest IP8M-2496EB-40MM bullet cam. In the last 24 hours the camera has made 16336 DNS queries.

To be honest even 36 queries are too much if I explicitly do not want the camera “phoning home”.

Thanks for the reply.

P2P was already disabled so I’m still seeing over 16K queries in a 24 hour period.

That link is useful also because it lead me to another thread where upgrading firmware helps (but doesn’t completely eliminate). Apparently I have to register (email etc) with Amcrest to get a firmware update?? grrrrr…

Today I noticed crazy amount of queries from my ASH26-W amcrest camera (90K in a 3 hour period), updated the firmware, it also got worse… I finally got it to stop by disabling stuff through the web API. These were the domains discovered through pihole: and

If your amcrest camera supports it, start with this command in a web browser (You’ll need the username:password) it will show you all the configs:


Eureka moment when I found the domains with the associated configs: T2UServer & VSP_PaaS

For example,T2UServer config looked like this:


Ran these commands to disable each feature:



If you use any Amcrest apps, these commands will probably break functionality use caution. I run all my cams locally with blueiris and HA, didn’t break anything for me.


OMG thank you, just set up a new firewall and had literally 800k DNS queries shot down in 36 hours from 4 cameras. Hopefully this is persistent across camera reboots!

1 Like

I have an Amcrest IP4M, there were additional thousands of call to
turns out that it was on the “Amcrest” config (http://[YOU_CAMERA_IP]/cgi-bin/configManager.cgi?action=getConfig&name=Amcrest) and that was cannot be turned off.

the only solution I got to avoid a tsunami of DNS calls was to replace that value with (I’m running the cameras locally with a firewall to prevent any outgoing traffic anyway)


Tested this setting, bit it does not survive a reboot and the values are back. Attempted this twice. Additionally, I tried to create and delete a test user to maybe generate a save event, but I always thought that any of the API setconfig commands write to the config in saved memory. Appears to be hard coded into the firmware to reset these values.

This post on github:

shows you how to automate config file changes in node red. Just thought I’d throw that out there.


My AD410 was requesting 450+ times / minute even with bogus DNS server addresses. The AD410 doesn’t have an internal webserver page and using the Amcrest app needs a live internet connection.

This solved the problem. I added it to my daily run script of shells to erase the watermarks and silence the flashing ring light. All because I refuse to let my cameras have internet access.