Amcrest camera questions

Trying to figure out if I can get some amcrest Cameras to work, The current integration only lists a few working devices, and I see that the code has not been updated for some time.

Is it still being worked on?

Current issue:

I have a IP5M-D1188EW-28MM that im unable to get working. Currently running HassIO, fully updated.


  - host:
    name: Driveway
    username: hassio
    password: !secret camera_password
    resolution: high
    stream_source: rtsp
      - motion_detected
      - sdcard


2022-10-13 22:06:02.552 WARNING (Amcrest Driveway) [amcrest.http] <Unconnected @> Trying again due to error: HTTPError('403 Client Error: Forbidden for url:')
2022-10-13 22:06:02.695 WARNING (Amcrest Driveway) [homeassistant.components.amcrest] Error while processing events from Driveway camera: CommError(HTTPError('403 Client Error: Forbidden for url:'))

Testing from command line:

curl\?action\=getMachineName -vvvv
*   Trying
* Connected to ( port 80 (#0)
> GET /cgi-bin/magicBox.cgi?action=getMachineName HTTP/1.1
> Host:
> User-Agent: curl/7.83.1
> Accept: */*
* Mark bundle as not supporting multiuse
< HTTP/1.1 401 Unauthorized
< WWW-Authenticate: Digest realm="Login to (sn here)", qop="auth", nonce="1240342542", opaque="4ab0ecbd8c591b69168e71a2e8739a1ee762db9a"
< Connection: close
* Closing connection 0

Ive tried this with the admin and user account on the camera. The camera does show in the logs the attempted login/logout hundreds attempts over several seconds.

I have another camera, and older model, ipm-751w that works fine. I also have a IP2M-841B that connects, but does not show any image. Those are also configured exactly the same, with only the IP address being different.

I have this camera working without issue using Amcrest integration

It is using admin user of camera with all authorities enabled.