Amcrest camera set up - help needed

I have HA installed on a RBPi3b+, and have connected a Philips Hue hub (all lights working) successfully. HA also detects my Bose Sound Touch 30 WiFi streaming speaker, and my Roku T.V. streamer.

Next, I am trying to configure an Amcrest IP3M-956W outdoor security camera. The camera is working and its interface is reachable both via Android tablet and Windows PC, but HA does not seem to be detecting it as far as I can tell. I do not know what entries are needed in the HA configuration.yaml file.

I have seen several examples, but it’s not clear to me what is needed in my case. I do not need remote access to the camera, and it is the only camera installed (so far). Per the HA instructions, I added the following lines to configuration.yaml:

username: “admin”
password: “my pwd”

I guess the above is incomplete and/or incorrect as the HA interface shows nothing I recognise. Also, motionEye add-on is not connecting to its web ui, I guess another config issue. Please advise.

When posting YAML code or messages from the log, please format correctly using the instructions at the top of the page so they can be read correctly. YAML is very sensitive to indentation, and when not properly formatted in a post here it’s impossible to see those kinds of problems.

Assuming you have the last three lines indented properly under the amcrest: line, then that should be all you need to get started, assuming the camera is on the default port of 80. Have you tried refreshing your browser (typically F5)? Do you see a camera entity on the States page? Are there any errors on the Info page and/or in home-assistant.log?

pnbruckner – thanks for the tip! I checked the indent/spacing, added a line for the port, and it worked – camera image now shows up on my HA interface. Nice.

I also now get an interface for the motionEye web ui, but the initial setup is not accepting my camera. I had assumed that because the camera was compatible with HA that it would also be compatible with motionEye (bad assumption ?).
Of course, again, I could be doing something wrong in the setup input.
Camera type: Network Camera
URL: as soon as I enter this, message appears:
“not a supported network camera”.

Sorry, don’t know anything about motionEye. And since you said “add-on”, I’m guessing you’re using hassio, which I also don’t use or know anything about. If you need help with motionEye, I’d suggest opening a new topic specific to that so people who have experience with it will see it and hopefully provide help.

I’ll move this topic to another area. Thanks for your time & help.
BTW, any relation to Anton Bruckner ?

Not that I’m aware of. :slight_smile: