Amcrest Configurations

Perhaps these have already been solved for but I’m unable to locate anything in the documentation.

-I’d like to turn off the overlay property entirely. It defaults to Amcrest Camera and overlays in the exact same location at the camera’s overlay. I want this property on the camera, as that goes with the recording. The documentation says you can add name: to customize it, but this field can’t be blank. How do I eliminate this overlay?

-I occasionally get “error loading image” errors in the GUI, and the log will fill with errors like this:
File "/home/homeassistant/.homeassistant/deps/amcrest/", line 60, in command timeout=timeout_cmd, File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 70, in get return request('get', url, params=params, **kwargs) File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 56, in request return session.request(method=method, url=url, **kwargs) File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 488, in request resp = self.send(prep, **send_kwargs) File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 609, in send r = adapter.send(request, **kwargs) File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/requests/", line 499, in send raise ReadTimeout(e, request=request) requests.exceptions.ReadTimeout: HTTPConnectionPool(host='hostname', port=port): Read timed out. (read timeout=3)

I noticed the frames refresh every 2 seconds, but I think I can remedy this problem by switching it to every 5 seconds or so and increasing the timeout. Is there anyway to accomplish this?

If it is relevant, I am running HA ver 0.35.3 on a raspi and am using Amcrest IP2M-841 cameras.

Thanks for your help.

Hello @avalanchevm,

Which property to do you want to overlay? Could you elaborate your current question?

Regarding the timeout, are you using WiFi or cable? Furthermore, on the camera’ s native software, are you how many connections are allowed?

On the next HA release, the amcrest will do a mjpeg stream and not based on screenshots anymore which will help on this issue.

Could you try installing the dev version to see if this will address the issue?

Allow me to elaborate: according to I can set the “name” parameter and it places an overlay or watermark on the picture that is shown. This defaults to “Amcrest Camera” and I can change it to something, but I cannot change it to nothing. The native Amcrest controls also let you place an overlay, which gets burned into any recorded video also. I prefer this, as I have an NVR doing the recording for me and just want to be able to take a peek with HA.

here is a screen cap of the view through HA:

and here is the same view through just the camera’s web interface:

regarding connections etc - i have 2 cameras and one is wired in while the other is on wifi. Max # of connections is set as 20, which is the max according to the GUI. I will attempt to install the dev version and test and report back.


Hello @avalanchevm,

Thanks for explaining the issue. Regarding the name issue on HA, the name is required for any given entity on HA. This is how HA will find and manipulate a device for example camera.amcrest_camera or any entity such as sensor.yr.

Having said this, the label displayed on HA will use the name if there is not a friendly_name configured. Since the name is mandatory there is nothing we can do about it, however you can set the friendly_name to an empty string and this should take of it.

  friendly_name: ' ' 

The result was the label being removed but the entity name was still the same.

You can refer to the link to see how to customize your devices.

Regarding the timeouts, try the dev version and let’s if that will help.

Please let us know if you need any further assistance.

Thank you!

ahhh yes, I can see the friendly name is filled in by default in the entities under developer tools. never noticed that before. thanks for the tip!

I’ve installed the dev version. It seems like it may be less frequent but it still drops off from time to time. I do notice the video update is less frequent, so I think that may help. I’ll watch it over the next few days and report back with my observations.

1 Like

Thank you @avalanchevm

So I’ve been running the dev version for a couple of days, and the ‘unable to load’ errors are definitely less frequent. Also I saw the updated documentation in your PR and saw that it is now user configurable. This will be great, as I’d like to add my other camera’s into HA too!

I am, however, having trouble configuring the sensor component that is upgraded in the new version. I am wondering if I might ask your assistance again:
The problem is that the cameras work as they did before OK, but the new functionality is not present. No badges, no info when I click the camera etc.

my configuration.yaml file entries:
#back door
- platform: amcrest
host: host
username: username
password: password
resolution: low

  - platform: amcrest
    host: host
    username: username
    password: password  
      - motion_detector
      - sdcard
      - ptz_preset

From home-assistant./log:

17-01-20 10:23:54 homeassistant.components.sensor: Error while setting up platform amcrest
Traceback (most recent call last):
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/helpers/", line 151, in _async_setup_platform
    entity_platform.add_entities, discovery_info
  File "/usr/lib/python3.4/asyncio/", line 388, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.4/asyncio/", line 286, in _wakeup
    value = future.result()
  File "/usr/lib/python3.4/asyncio/", line 277, in result
    raise self._exception
  File "/usr/lib/python3.4/concurrent/futures/", line 54, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/home/homeassistant/.homeassistant/custom_components/sensor/", line 76, in setup_platform
    sensors.append(AmcrestSensor(config, data, sensor_type))
  File "/home/homeassistant/.homeassistant/custom_components/sensor/", line 99, in __init__
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/util/", line 296, in wrapper
    result = method(*args, **kwargs)
  File "/home/homeassistant/.homeassistant/custom_components/sensor/", line 129, in update
    version, build_date =
ValueError: too many values to unpack (expected 2)

Your thoughts and insights would be appreciated.

Hello @avalanchevm,

The problem for this is because the camera/ is still pointing to the amcrest==1.0.0 while the sensor/ is pointing to amcrest=1.1.0.
The best way to address this problem is to grab the already committed in dev version the camera/ and sensor/ and remove the deps/amcrest* python modules.
Once you do this, it should work as expected.
Please let me know if that addressed the issue.

1 Like

@avalanchevm, I just noticed that you mentioned that you are already running dev. In this case, make sure you fetched the latest commit in dev and then remove the deps/amcrest* files which should fix the issue.

1 Like

thanks for the quick reply.

I deleted the 3 amcrest directories and their content and restarted HA. The error log showed quite a few errors and the 3 directories repopulated themselves. I restarted HA again and now have 3 new badges for each camera.

thanks again!

1 Like

The solution to REMOVING the Amcrest LOGO is pretty simple:

  1. Open a browser and enter the IP address into the address box as
  2. the remaining steps are shown in the attached image: Enter IP into address bar - Login - Select SETUP - Select CAMERA - Select VIDEO - Select OVERLAY - Select LOGO OVERLAY - Select DISABLE - Select SAVE.
  3. That’s it.