Amcrest DN410 2 way audio with cloudflare and Kemp loadmaster

I’m fairly new to home assistant. I’ve really been enjoying the flexibility and the capabilities. Like the title suggests I’ve been trying to get two way audio to work off and on for a while now. I think I’m getting closer. I’ve been going over this video for guidance but have a couple of differences in my setup than he has.

My setup has go2rtc running in a docker container. I have Cloudflare handling my ssl certs and it points to a Kemp loadmaster handling my load balancing. I have one DNS A record for go2rtc and one for home assistant. I’m able to connect to the doorbell 2 way page directly and every browser that I’ve used (chrome and safari) show that they recognize the cert.

I’ve changed the codec for the doorbell and am able to hear the audio from the doorbell. In the video Roger mentions the fact that someone came up with an intermediary url to enable the microphone. I was also able to get this setup and setup the iframe card on a dashboard pointing to that intermediate url, but still no sign of the microphone or a prompt to ask me about using the microphone.

Does anyone have any suggestions about how I can get the two way communication working?