Android actionable notifications

notification
Tags: #<Tag:0x00007f47fe1541e8>

#61

Does the Android Notifications require external access to HA? As in having DuckDNS setup?

Thanks


#62

You don’t need to open any ports for the notifications themselves, but you need some kind of external access in order to trigger an action from a notification properly, i.e. access through a VPN or an open port.


#63

Is it correct to assume that “server_key (OPTIONAL: only if using your own FCM Project): MYSERVERKEY123456” can be omitted from the configuration?

Like this…

notify:

  • name: android
    platform: fcm-android

I have that in my config yaml, restarted home assistant, Installed the app and put my home assistant address and my http: api password and I keep getting “Something Went Wrong”

Am I doing it all wrong?

Thanks


#64

@dmoses1969 Correct, you can omit the server_key from your configuration.yaml. Are you trying this on your local network? If so, trying using the IP address like http://192.168.0.154:8123. Are you including the port number? I’m just trying to throw out anything I can think of.


#65

I have tried both http:// ip of my pi3 with and without :8123. Each time clearing data in the app just in case it. I downloaded an app from Google Play Store, https://play.google.com/store/apps/details?id=com.axzae.homeassistant and entered my ip and password and it connects just fine. Just doesn’t have the notification option as far as I know.


#66

@dmoses1969, that’s a completely different app.
You need to down-/sideload the apk from @Crewski’s github page:


#67

Did you put the fcm-android.py file in your custom_components/notify/ folder and then reboot?

The homeassist uses Websockets which are automatically installed when you use frontend. Mine needs the fcm-android.py file in order to setup the endpoints and service.


#68

Amazing! Just what I needed! Works like a charm from what i have tested. Thanks for putting in the time!

Any chance we can combine this with the HomeAssist app?
Seems the Android mobile app is a way behind the iOS version - this will go a long way to bridging the delta.


#69

Yes, \config\custom_components\notify\fcm-android.py

I’ll try deleting it all and started over this evening when i get home.


#70

Andy idea of this van work on android tv?


#71

There’s already a platform for Notifications for Android TV that works offline (without Firebase), just in case you weren’t aware of that.


#72

Deleted everything, rebooted, Copied a new fcm-android.py file in custom_components/notify/ folder
Added the lines below in my configuration file.

And HA displays this alarm…

Configuration invalidCHECK CONFIG
Platform not found: notify.fcm-android

Could it have anything to do with the new auth setup in the latest Hassio?

I know thats not formatted correctly in this post but I cannot seem to get it formatted using the code blocks


#73

It shouldn’t have anything to do with the new Auth system since I think the REST API still falls back on the legacy api password…though I’m not 100% sure of that.

Have you made any progress on getting it to work by chance?


#74

I tried all weekend to get it to work with no success. Keep getting “something went wrong”. Only asking about the new authorization thinking it had something to do with hassio needing a login and password. I thought I read something using the legacy api password after upgrading to the latest hassio. I’ll see if I can find it and maybe try reverting back to that and see if it works.

Thanks


Home Assistant Android app?
#75

Hey guys, I threw this into the HomeAssist app. I forked the repository then added my stuff in. Registering/Unregistering for the Push Notifications is found in the Settings. I switched from Volley to Retrofit to match what was already in the code…everything should work with the current fcm-android.py. Here is the apk.

https://github.com/Crewski/homeassist/blob/master/generated%20apk/homeassist-hanotify-4_0_0.apk


#76

The new APK will not install on my Pixel XL. Did it really go from 3.27MB to 10.33MB in size?


#77

what a hero! thanks, will give it a whirl tonight


#78

I’m guessing that you have the play store version of HomeAssist installed. My apk can’t overwrite that since it isn’t from the same author. You need to uninstall the other version first, then install mine.

The apk I provided is just the debug version. I didn’t run a production build, sign, and zip-align. I would expect that to drop the size back down. I only added 2 Kotlin files, 2 models, and a couple other lines of code. Nothing major by any means.

UPDATE
I went ahead and signed a release apk, which brought it down to about 8.9MB. Obviously still a lot higher than before. I’m not really sure what the change is. Feel free to poke around and let me know if you figure it out. Thanks.

Here is an easier link for mobile:
https://drive.google.com/open?id=17q0VR3T96k0SyQYujfpbNipAI33jdEYZ


#79

Opened the new app in Android Studio Debug and it says "Libraries (*.so) in the APK are missing debug symbols. If that helps.


#80

Unfortunately I’m not sure on this one. Maybe try my HomeAssist fork I just posted and see if that will work.