Android App - Connection Refused Error On My Wife's Phone - Works On Mine

I recently installed the Home Assistant app on my Android phone Pixel 4 XL. I went through the Duck DNS and HTTPS setup and everything to get it working on my own phone, once I got everything setup correctly I was able to login to Home Assistant on my phone no problems.

I installed the app on my wife’s phone, Samsung A3 I think it is, typed in the https:// like I did on my own phone and I get a connection refused error message. I’ve been trying for a few weeks to get this to work.

I’ve looked through a number of posts about clearing cache, uninstalling and reinstalling the app, enabling and disabling this and that on the the phone, but nothing has worked.

Does anyone know if two phones using the same address to connect causes a conflict? Or is there something else I need to do so she can connect through her phone?


if that is the URL you manually typed in that is not correct.

you should be entering only

Thanks. I think I tried it with and without the /onboarding.html . I’ll try it again when I get home.

I tried it again, this time:

Still the same error.

“Error Code: -6”
“Description: net::ERR_CONNECTION_REFUSED”

connection refused is not an error the app can solve, are you using a proxy or anything? I would check your network setup.

I’ll look more carefully through my network setup. I’m not using a proxy at all. Her phone accesses the internet through my router same as mine. Other than the phone model, there shouldn’t be any difference in accessing the network, as far as I know.

does the same device work in chrome for android?

Do you mean accessing Home Assistant through Chrome instead of the Home Assistant app?

yup just to see if it works.

I don’t have access to her phone at the moment. I tried connecting through my desktop PC using Firefox instead of the local access I usually do. I can’t connect either though my browser.

Unable to connect

An error occurred during a connection to

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Something sure is blocking it.

yea im not sure may want to look up how you setup duckdns and all that to see where the problem is

I think I may have figured it out. I’ll have to test it on my wife’s phone when I get home tonight.

I think the problem was with the port forwarding on my router. It gives you a list to choose from when you create a forward http, etc. . . I chose http when I set it up based on a video I saw when I first set this up. In the router when I chose http it defaulted to an external port of 80. Based on an article I read today it says to set the external port to 443 and an internal port of 8123. That didn’t work through my browser on my desktop but I noticed in the screenshot of the person who wrote the article they also had a port forward internal and external of 8123. When I did that along with the port 443 the dashboard loaded in my browser. I then tried to connect through the app on my phone but it didn’t work anymore. It did give me the option to go to the configuration page where I noticed that along with the duck dns address I had :80 instead of :8123. I may have put that when setting it up the first time since my router automatically put 80.

I guess that why I could connect, my router had 80 and my phone was initially set to 80 but I was trying to use :8123 on the browser. So after setting my app and the browser to :8123 they both work. Hopefully it will be the same for my wife’s phone when I get home tonight.

To clarify:
Old forwarding:
mode: http
External Port 80
IP: my home assistant IP
Internal Port: 8123

Corrected forwarding:
Mode: HTTPS (I manually typed HTTPS)
External Port: 443
IP: my home assistant IP
Internal Port: 8123

and I created a second forwarding

Mode: HTTPS (I manually typed HTTPS)
External Port: 8123
IP: my home assistant IP
Internal Port: 8123

After the second forwarding I could access through my browser


Had the same issue, I had entered, but you should not specify a port, as you should already have port 443 forwarded from duckdns directly, i.e. leave the port numer out and forward port 443 internally to your Home Assistant address.