Android app keeps closing on Fairphone 3 - Fixed

Strange issue here, but I don’t think this is a Home Assistant app issue, even though this app is affected. First of all, I had a problem with the Lloyds bank app not opening, and giving me an message saying “App keeps closing”. In the end I removed and reinstalled the app, and this problem went away. The Home Assistant App has now started doing the same, but re-installing doesn’t fix it.

  • I am running Android 10
  • I have tried restarting the phone at various points when uninstalling and re-installing, but without any positive result.
  • Both the Lloyds app and Home Assistant have been running happily for several weeks.
  • There haven’t been any update events on the phone demarcating functioning and non function apps.

Has anyone else seen anything similar to this?

I’ll keep looking for more general information, and if I resolve it I will post back here.

ps: I love the app - it found my home assistant installation without any issues, and off it went!

Ok - fixed it. Seems to have been related to Android 10 update at the start of March. I cleared the cache and data, then re-connected the app to my Home Assistance instance.

  • I’ll mark the title as fixed as well…