Android app locks up on attempt to edit Automation or Scene

Almost anything I try to do in Configuration/Automations and Scenes causes the app to lock up; I have to close and reopen it. I can view the lists of automations and scenes, but can’t edit any of them, or see history, etc. I can execute a Scene, but trying to leave that screen via the Back arrow also locks the app.

Other things work fine. I can use all the entity cards I’ve put on my Dashboard.

I just installed the latest app update, no change. It’s been this way forever, and I have to ask the usual question: is it just me?

This is not a lot to go by. What device is this issue on? What app version is installed? What version of webview is on the device? Do you see the same issue using chrome for Android on the same device? So you have custom cards?

Samsung Galaxy S8. I can’t access my local HA instance on mobile Chrome, because homeassistant.local:8123 isn’t resolved by DNS on the phone. At one time I’d figured out why, but forgot the answer because I just used the app.

The app is the latest version from the Google Play store. No custom cards, just standard Lovelace. Like I said, other things in the app work fine, but trying to view or edit an automation or script is instant death and always has been.

I’m not even looking for a solution - really just want to know if this is a known problem with the app.

then you cannot expect the app to work in these cases

does this happen in chrome for android on the same device?

As I said, I can’t access HA in Chrome on Android - I’d have to resolve the local DNS problem. But I have no problems using HA locally from Chrome on my PC.

as you are using homeassistant.local then just use the IP address of your HA server to connect, take DNS out of hte equation.

as your problem is with the app you cannot compare to desktop chrome, it must be chrome for android

I got in via Chrome as [IP]:8123, tried to edit an automation, and the page locked up just like the app. Chrome itself wasn’t dead, I was able to close the page.

What’s the relationship between the app and Chrome?

This means that the issue is not related to the app but the HA frontend, you should open an issue there.

the app uses android system webview which is based off chrome, we compare it to see if the issue still occurs to help understand where the issue is.

1 Like

Chrome is out of date on my phone. I’ve been declining updates because they only cause problems. But given this dependency I’ll take a chance and update Chrome.

Following the update of Chrome, I was able to edit a couple of automations. Never got that far before, so maybe this problem is solved. At least I understand it better. Thanks for the replies.