Android APP "Unable to connect to Home Assistant"

Hello everybody,
the Android app has been working great the last months THANK YOU. After a SD card failure I had to do a new installation of HASSIO 0.103.4. Since then I can’t connect to my server with the Android App anymore! App 1.3.3 newly installed - Android Honor EMUI version 9.1.0 Android version 9.
After the installation comes a short “Loading Data” and then in an endless loop “Unable to connect to Home Assistant”. In the log I found the following -> Login attempt or request with invalid authentication from 192.168.178.10
There is no possibility to enter the login data manually.
Greeting Jürgen

Update:
On a “virgin” Android phone the app works on the first go - connection to my “hassio:8123”
The app was already connected to an older version/old server on the 1st phone!
The app has already been uninstalled several times and the phone has been rebooted.
If the server (HA Instand) is down and it is tried to access the server I get the following error message:
The website at http://hassio:8123/? Exteral_auth=1

Update:
when reinstalling the app on the 1st mobile phone NO network scan is done, as if there is still something left from the old installer!

Update:
HASSIO shutdown
uninstall the app on your mobile -> reboot your mobile
App newly installed via the Google Paystore
Open the app -> No network scan -> Error message
The website at http://hassio:8123/? Exteral_auth=1 net::ERR_ADDRESS_UNREACHABLE
but the app can’t know this -> ergo the app will not be completely uninstalled!

Same problem, but using an iPhone

Same here from day one the app came out.
Error message
Logging in with Home Assistant Local.
Error: invalid client id or redirect uri
Can not filling in anything.

Use https://name.duckdns.org:8123
And local access will not find any hassio

Had a similar problem a few minutes ago when I changed the host name of my Home Assistant. The app on my Android would only say “Unable to connect to Home Assistant.” It would never let me change the settings.

I went into the settings of my phone, then into “Apps & noticifications”, then All Apps. Find Home Assistant and clear the Cache and Data. It’ll warn you that it will remove all data and settings - GOOD!

Once you do that, you should be able to enter the settings again. It may differ a bit depending on your Android version, and I know it also exists somewhere on the iPhone (iOS) too.

Hopefully what I did will help out for you all.

1 Like

Hello Steve,
thank you very much, my problem is solved!
It makes a difference if you uninstall an app or if you delete the cache, but anyway it works again.

Cleared storage and cache and I’m still having this issue. Any other ideas?

2 Likes

Same as Nordic, tried the fixes and I still have the issue. It seemed to work reliably for me for a few initial months, and the issue surfaced for me a couple of months back. Using Chrome browser on Android has no problems. I’ve cleared data, re-installed, re-set up multiple times.

i have samsung s5 with lolipop 5.1 and after i change my domain name the app unable to connect. in chrome from andriod its work, also if i only set the local ip its also work with the app . its looks that the problem on the external address but in other phone have no issue.
any idea ?

Same problem on all four of the mobiles in my household. Has there been any solution posted here?

Not that I’m aware of. I’ve just reverted back to using Chrome on my mobile (Add it to your home screen so it acts a bit more like an app). No issues with that. But you lose some features.

I think it had something to do with SSL. I recently enabled that for my ddns access and it seems to have hosed up my local access. If I only use my ddns access, it works fine. I tested that with only using mobile data and no wifi. If I try only wifi and local access, it gives me the unable to connect message

I must be something to do with SSL. I have a Galaxy Note 10+ and the Home Assistant app was working just fine both inside and outside of my network until I added my SSL certificate to Home Assistant. Here’s my situation:

I have my own domain name purchased through Google, so no need for DuckDNS. I also have my own SSL certificate which I use for UniFi and now Home Assistant. Before installing my certificate, I could access Home Assistant via an internet browser or the app inside of the network using http://192.168.XX.XX:8123 and outside of the network using https://name.domain.com:port. I got annoyed with the warning the web browser would give me when outside of the network. So I installed my SSL certificate in HA. That fixed the issue when accessing HA from outside of the network.
However, I noticed that when accessing HA from inside of the network, I now had to use https for the internal address instead of just http. With https inside of the network, I can access HA. I just get the annoying warning from the web browser about the certificate, which I understand because the certificate is for the domain name and not the internal HA address.
Now, in the app, I cannot access HA from inside of the network. I even changed the internal address to https in the app settings. The app only works when inside of my network if I completely remove the internal address from the app settings.

I know some people say just leave it that way, but I would like to have HA be able to operate without the internet if need be.

I’ve tried just about everything. I’ve reset the app. I’ve uninstalled and reinstalled the app. It’s got to be something with SSL. When I removed the certificate from HA, the app worked again from within the network with the http internal address.

1 Like

I have a similar scenario to yours…

Same problem. If reinstall works ok 1 day.

I have a similar problem. I was able to use the android app and my desktop Windows 10 no problem. Then I changed my router to an access point and the Android app would no longer connect. I have no trouble connecting with the windows 10 machine.
Bob

Same problem

Same problem…

Try updating android web viewer on your device

Been doing that. Still nothing.

It’s amazing. All of these updates to HA and the app lately and this issue STILL has not been fixed.