Android device geocoded location not updating

as workaround im using this Component, wich works fine for me.

I just came across this thread. Can confirm this is still an issue with a one plus 9 pro.
The geocoded location is working correctly, but the actual ‘gps’ component was showing Unavailable.

I think I found something that might have fixed it… Go to the companion app, Single Accurate Location, and then make sure “include in sensor update” is flicked on. For some reason that was off for me, and everything had been working fine up until about a month ago. I flicked this on, and GPS has come back to life, and my tracker in HA immediately showed as “home”

There is a reason why that toggle is off by default and that is because this option will drain your battery at a faster rate.

Instead you should follow the device tracker troubleshooting steps

A better link: Troubleshooting | Home Assistant Companion Docs

1 Like