Android mobile_app Notify + TTS Stopped Working

seems like an issue that would be affecting others but I wasn’t able to find any discussions regarding this. I have a personal phone (mobile) + 2 old phones (static) I use for announcing things like “welcome home”, “good night”, etc. that were using the following text-to-speech automation without issue until recently…

service: notify.mobile_app_xxx
data:
  message: TTS
  title: hello

…now when the service runs it flashes a toast on my device…

Unable to process notification "hello" as text to speech.

…I’ve poked around but I don’t see any config options in the app. strange that all my devices (oldest is still running Android 7) stopped at the same time.

service: notify.mobile_app_xxx
data:
  message: TTS
  title: 'hello'
  data:
    ttl: 0
    priority: high
    channel: alarm_stream_max

/
Home Assistant 2022.3.5
Android HA 2022.3.0-full
Notification as text

service: notify.mobile_app_xxx
data:
  message: test
  title: 'hello'
  data:
    ttl: 0
    priority: high
    channel: alarm_stream_max

Voice notification (TTS)
It works very well

service: notify.mobile_app_xxx
data:
  message: TTS
  title: 'hello'
  data:
    ttl: 0
    priority: high
    channel: alarm_stream_max

not working for me. non-TTS works as expected tho, ie…

service: notify.mobile_app_xxx
data:
  message: test
  title: 'hello'

…just any time ‘TTS’ is the message it fails.

the above is working for you currently?

I should mention that I’m on the current Docker build… Home Assistant 2022.3.5

Working for me (Android 10), using HAOS in VirtualBox.

service: notify.mobile_app_sm_a205u
data:
  message: TTS
  title: 'hello'
1 Like

for anyone else that stumbles across this with the same problem, was able to get it working on one device (Android 11) by clearing app data for an app called “Speech Services by Google”. the older devices are still not working but I’m guessing it was a change from Google and hopefully I can figure out how to get them up again also.

cheers.

I have the same problem but I can’t solve this…
And stop working after an recent update of HA…
I already clear the app data of “Speech Services by Google" but don’t solved.
The TTS says something like “Please set a type for text-to-speech to be processed”…

I don’t know what’s necessary :roll_eyes:

UPDATE:
The TTS says this: “Please set a title for text to speech to be processed” (which is a direct translation from Portuguese to english by google :smiley: )

It’s very strange because I call the Notify service like this:

service: notify.mobile_app_s10
data:
  message: TTS
  title: example text to say

I Also have the google “speech synthesizer” instead of samsung.

because of this issue I realized that Google’s TTS implementation doesn’t render anything locally, it sends the text to cloud servers that generate the voice and send it back. I’ve since moved to a local android TTS provider called RHVoice which is much quicker to respond (no more delays in voice rendering) and has been problem-free so far.

Hi! I’m having the exact same problem. Everything was working fine until an update and it stopped working. I also deleted the data of the “Speech services by Google” without luck.

I tried installing RH services as a replacement but it’s too complicated for me (no python knowledge)

Has anyone came up with a solution?

Thanks!

why you would need python knowledge? install the RHVoice app, change the TTS engine to RHVoice, that’s pretty much it unless you want to mess with the voice sound/speed.

To fix TTS saying “Please set a title for text to speech to process” even when title is already set,
you need to add:
tts_text: example text to say

reference: Update android parameter names (#589) · home-assistant/companion.home-assistant@5cc1824 · GitHub

9 Likes

thanks a lot!!! The companion docs that I consulted before posting here weren’t up to date… but now there’s a reference there (although it says “BETA”).

Thanks for pointing me in the right direction!

I’m having this issue also - do I add tts_test: example text to say to configuration.yaml or to the Title field in the automation?

I found how to fix it:

service: notify.mobile_app_xxx
data:
  message: TTS
  data:
    tts_text: System armed

Or alternatively,

9 Likes

That solved the problem for me. Thanks

Fixed. Thanks man

To make it compatible with Speech Services by Google and RHVoice you have to have both title and tts_text. Google won’t work without tts_text and RHVoice won’t work without title. I use a script like below for my family (kids) to send tts to one another.

service: notify.mobile_app_xxx
data:
  message: TTS
  title: "{{ states('input_text.tts_message') }}"
  data:
    tts_text: "{{ states('input_text.tts_message') }}"
2 Likes

Same issue here, they updated it in the companion app 2022.8, but didn’t put info anywhere how to adjust the TTS notify service scripts :frowning:
But the above script seems to work!

Thanks a lot! Works for me!!!

Thanks everyone. Works for me.

Wonder if anyone can help - I’m trying to set up my TTS for the first time - i’m using Node Red but it follows the same rules

Seems whatever I try I get the “please set a title for text to speech to process” announcement… I’ve tried adding title everywhere!

{"message": "TTS", 
 "title": "The house is on fire and the cat's stuck in the dryer!",
 "data": {
    title: "The house is on fire and the cat's stuck in the dryer!",
    ttl: 0,
    priority: high,
    media_stream: alarm_stream_max,
    tts_text: "The house is on fire and the cat's stuck in the dryer!"
    }
}